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Purpose 

 

 This document is intended for users of the Tariscope Enterprise 4.x and Tariscope 

Provider 4.x editions. Further in the text, if there is no need to clarify the edition, the 

Tariscope name is used. This guide describes all features of the Tariscope applications except 

the Tariscope configuration and maintenance. 

 The Tariscope configuration and maintenance are described in the Tariscope 4.x. 

Administrator’s guide. 

 

 

Introduction 

 

There are two editions of the Tariscope system: Tariscope Enterprise and Tariscope 

Provider.  

The Tariscope Enterprise edition is a call accounting software for companies that have 

one or a group of PBXs. 

The Tariscope Provider edition is a telecom billing system for telecommunications 

service providers. 

Further in the text, if there is no need to clarify the edition, the Tariscope name is used. 

The Tariscope system: 

• provides a collection of information about calls from various data sources, such as a serial 

port, Ethernet port using TCP, UDP, FTP, and SFTP, local and remote folders, databases, 

etc.; 

• collects information on Internet use from a range of data transmission equipment using 

NetFlow (version 5, 9), IPFIX, rFlow protocols; 

• processes the received information with a definition of the subscriber who made or 

received a call, with a call and data traffic rating;  

• carries out a search of the desired information about the calls or received / transmitted 

data using filters of different levels of complexity; 

• creates reports with text and graphic information; 

• assesses telephone traffic for routes, trunks (lines), or subscribers; 

• includes a customer account management (only for the Tariscope Provider edition); 

• compares the results of the Tariscope rating with the results of rating from your telecom 

service provider; 

• interacts with other systems, for example, hotel, accounting, CRM, and others; 

• manages telecommunications equipment using money or time limits on the volume of 

calls made or the use of Internet services; 

• gives a customer (subscriber) access via the Web interface to get information about the 

customer (subscriber) account, call details, data traffic and allows an issue to be sent to 

get help or obtain information, etc. 

 

The Tariscope user must possess certain skills in the telephony services provided to 

subscribers (customers) and / or the Internet services. 
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 Chapter 1 Getting started with Tariscope 

 

Getting started with Tariscope the Tariscope administrator must perform the following 

actions: 

• to install Tariscope; 

• to activate Tariscope; 

• to configure Tariscope. 

These actions do not describe in the document. How to install, activate, and configure 

Tariscope, see in the document “Tariscope 4.x. Administrator’s guide”. 
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Chapter 2 Tariscope applications 

 

The Tariscope system contains the following applications that can be used by the 

Tariscope user: 

• the Tariscope program; 

• the Report Designer program, 

• Tariscope Personal Area. 

 

 The Tariscope program provides the performance of the main functions of the 

Tariscope user: 

• browsing information on completed calls, sorting, filtering, and highlighting for 

certain categories of calls; 

• browsing information on IP traffic; 

• a creation of reports with text and graphic information; 

• processing previously stored call logs; 

• an import of calls data from telecom service providers into the database; 

• a comparison of the results of the Tariscope rating with the results of rating from your 

telecom service provider; 

• a call re-rating; 

• charging telecommunication services to customers’ accounts (only for the Tariscope 

Provider edition); 

• a print of data of the views for calls or IP traffic; 

• an export of data of the views for calls or IP traffic and reports into external files of 

the following formats: Excel, Access, HTML, CSV, PDF; 

• an assessment of telephone traffic for routes, trunks (lines), or subscribers; 

• Subscriber Data Management; 

• configuring Tariscope. 

 

 The Report Designer program allows you to edit the Tariscope report forms or create 

the own report forms. In addition, the Tariscope system supports a generation of the Report 

Definition Language (RDL) reports. 

 

 Tariscope Personal Area allows a subscriber (customer) using Web interface: 

• to view information about the subscriber’s calls, IP traffic, and their costs; 

• to view information about calls of a subscriber group if the subscriber has appropriate 

rights; 

• to set a category for any call, for example: Private, Business, Partner, etc.; 

• to view and edit personal information; 

• to view his account status; 

• to execute payments for telecommunications services; 

• to get different documents such as calls reports, invoices, agreements, etc.; 

• to find a required area code; 

• to find a required phone number in the corporate telephone directory; 

• to send an issue to the Tariscope administrator. 

The Personal Area is accessible on a computer, tablet or smartphone. 
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Chapter 3 The Tariscope program 

 

3.1 Purpose 

 

 The Tariscope program is a main program of the Tariscope system. It allows you to 

analyze calls data and IP traffic, manage customer accounts (this feature is only available to 

the Tariscope Provider edition), and configure the Tariscope system. 

 The main features of the Tariscope program enumerate in Chapter 2. 

 

3.2 System requirements 

 

 To work with the Tariscope program you need a computer with the following 

parameters or above: 

• CPU 1,5 GHz or higher; 

• Memory: 2 GB or higher; 

• Hard disk space: 100 GB or higher; 

• Operating system: Windows 10/8.1/8/7/2012 R2/2012/2018 R2/2008 (Microsoft). 

The computer must have .Net Framework 4.5.2, which is included in the Tariscope 

installation package. 

 

Basically, the computer parameters are determined by the Tariscope database volume, 

with which it is supposed to work, and the required processing speed of data. 

 

 

3.3 Installation 

 

The Tariscope program can be installed with other Tariscope applications on the same 

computer. If you want to install the Tariscope program separately, during the installation, 

select the Client applications only or Tariscope version update check box. A description 

of the Tariscope installation, refer to the document:  "Tariscope 4.x. Administrator's Guide". 

 

 

3.4 The interface of the program 

 

  After the initial start of the Tariscope program, the Tariscope Initial Configuration 

Wizard is started. A description of the Tariscope Initial Configuration Wizard is given in 

"Tariscope 4.x. Administrator's Guide". 

  At start of the program the Connect to Tariscope server window appears as shown in 

Figure 3.4.1. 

In the Server name box, type a computer name or its IP address where the Tariscope 

server was installed. If the Tariscope server works on the same computer, you can type 
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"(local)" or "." in the box. 

 

 
Figure 3.4.1 

  

 In the Authentication list, select from the following options: 

• Windows Authentication, 

• SQL Server Authentication. 

For the first option does not require a user name and password. The authentication is 

performed by the name and password used to connect to the Windows. 

 When you select the SQL Server Authentication, you must type a user name and 

password. By default, in the system the sa user with password: Tariscope123 is used. The 

Tariscope administrator can change these parameters or create new users. 

 If at the next starts of the program, you do not wish to specify the parameters each time 

in this window, select the Auto connect next time check box. Not recommended to select 

this check box if several users have an access to the computer. 

 Click Connect. 

  

  After the connection to the Tariscope server the Tariscope window will be as shown in 

Figure 3.4.2. 

  The window contains the following sections: 

• Menu, 

• Toolbar, 

• Views.   

 

A view means a separate program tab that displays a certain kind of information. The 

Welcome and Output views are displayed in the Figure 3.4.2. 
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Figure 3.4.2 

 

  Not all menu items are available in some operational modes of the program. The menu 

contains the following main menu items:  

• File. This item provides a connection and disconnection to / from the Tariscope server 

as well as opening a file, print and export of a view data. 

• Edit. This item allows you to find, copy and paste data, to use bookmarks. 

• View. This item allows opening data views, filter views, the output view or the search 

view. 

• Data. This item provides a creation of a new data view, report or diagram (chart), 

sorting data, and setting parameters of any view. 

• Filter. The item allows you to set filter conditions to data and save them for future 

application. 

• Parse. The item allows you: to process call data from a previously saved CDR log; to 

import call data into Tariscope from an external file received from a telecom provider; 

to compare the results of call rating made by Tariscope with the results of call rating 

from a provider; to rerate CDR data; to remove duplicates from the call table; to clear 

charges of subscribers. 

• Tools. The menu item allows you: to archive calls data; to start the Tariscope Report 

Designer or Tariscope Management programs; to start the Tariscope mode that allows 

working with subscribers’ accounts; to configure the program parameters. 

• Window. The menu item provides the ability to switch between the Tariscope views. 

• Help. The menu item provides an access to the help information and allows activating 

the program. 

 

  The toolbar contains a set of icons which provide a quick access to a specific function. 
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The menu items and the corresponding keyboard shortcuts, a list of all the icons of 

toolbar and their brief description are listed in Table 3.1. 

 

Table 3.1 
First 

menu 

level 

Second 

menu level 

Keyboard 

shortcut 

Toolbar icon Description 

File Connect 

Tariscope 

Ctrl+W 
 

Provides a connection to the Tariscope server. 

Disconnect Ctrl+D 
 

Provides a disconnection from the Tariscope server. 

Open file Ctrl+O  Provides opening an external file. 

Save Ctrl+S  It allows you to save a file or a view data. 

Save as Ctrl+Alt+S  It allows you to save a file or a view data with a new 

name. 

Export   Provides an export of a view in an external file of 

the following formats: PDF, HTML, Text, and 

Excel.  

Print Ctrl+Alt+P  Provides a print of a view or file. 

Print 

preview 

  The item allows you to preview data before printing. 

Exit Alt+F4  It provides an exit from the program. 

Edit Undo Ctrl+Z  The item erases the last change done to the 

document. 

Redo Ctrl+Y  The item performs an action again that has been 

deleted by an undo function. 

Cut Ctrl+X  The item allows you to cut the selected data. 

Copy Ctrl+C  The item allows you to copy the selected data. 

Paste Ctrl+V  The item allows you to paste the selected data. 

Select all Ctrl+A  Selects all data of the view 

Find F3  The item allows you to select all data of a document. 

Go to Ctrl+Alt+G  The item allows you to go to a specific row of the 

table. 

Copy table Ctrl+Alt+C  The item provides a copy of the table. 

Bookmark Ctrl+Alt+B  A bookmark is set on a selected row of the table. 

The bookmark is highlighted in blue. 

Previous 

bookmark 

Ctrl+Alt+P  The focus returns from the current bookmark to the 

previous bookmark in the table. 

Next 

bookmark 

Ctrl+Alt+N  The focus is set on the next bookmark in the table. 

Clear 

bookmarks 

  The item clears all bookmarks in the table. 

View Data views F6 
 

Displays a new view that contains a list of the built-

in and saved views. 

Filters F7  Displays a new view that contains a list of the built-

in and saved filters. 

Output   Displays the Output view that contains the 

Tariscope log. 

Start page   Displays the Welcome page. 

Other 

windows 

  The item contains submenu included the following 

items: 

Related records. Displays the Related records 

view. It contains the related call records that appear 

when a call transfer, conference or similar functions 

are used. 
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Search. Displays the Search view where a list of 

records, which is a result of the Find function, is 

displayed. 

Data New data 

view 

Ctrl+N  The item provides a creation of a data view for calls, 

services or IP traffic. 

New report F9 
 

The item provides a creation of a new report. 

Traffic 

measurement 

 
 

The item provides a creation of a chart of call traffic. 

New chart  
 

The item provides a creation of a chart on the view 

data. 

Back to 

saved 

document 

F10 
 

If you have applied a filter to the view data, the item 

allows you to return to the saved data. 

Save as 

default 

Ctrl+Alt+D  The item allows you to save the view parameters as 

default. In future when you create a new view these 

parameters will be applied. 

Refresh F5 
 

The item allows you to refresh the view data. 

Run Ctrl+F5  The item starts SQL query from the open specific 

file. 

Stop Shift+F5 
 

The item allows stopping the Tariscope process 

such as a parsing, rating and so on. 

Sort  
 

This item provides a sorting by any field of the table 

or a group of table fields. 

View fields   The item allows you to select fields that will be 

displayed in the table. 

Coloring Ctrl+J  The item allows you to highlight rows in color 

depending on their data. 

Rows limit Ctrl+R  The item provides setting a limit on the row number, 

which will be displayed in the table. 

Data source   Shows a table name that is displayed in the view. 

View style   Allows you to configure a font and background 

color for the view. 

Filter Filter Ctrl+F 
 

The item allows you to set filter conditions using a 

graphic interface. 

Save filter Ctrl+F7  The item allows you to save the current filter 

conditions. 

SQL filter Ctrl+Alt+F  The item opens a window that allows you to create 

a SQL query of any complexity. 

Filter by 

selection 

Ctrl+Alt+O  Filtering is performed on the value of selected cell 

of the table. 

Exclude 

selection 

Ctrl+Alt+I  Filtering is performed, at which the data sampling 

excludes records that contain values similar to a 

value of the current table cell. 

Previous 

filter 

Ctrl+Z  The conditions of the previous filter are applied to 

the view. 

Next filter Ctrl+Alt+Z  The conditions of the next filter are applied to the 

view. 

Clear filter Ctrl+M  The item allows clearing all filter conditions. 

Parse Transfer Ctrl+P  Data from a CDR file are processed and saved into 

the Tariscope database. 

Compare   Performs a comparison of Tariscope call rating with 

call rating of the telecom service provider. 

Import calls 

and services 

  Call details and service details are imported from 

external files into the Tariscope database. 

Rate Ctrl+T  Call rating is performed for records of the view. 
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Recalculate 

month 

  Performs clearing charged services for the current 

month and the calls costs of this month. After this 

Tariscope performs the charging of service costs and 

calls costs. The entered payments from customers 

aren't cleared. This function does not work when the 

restriction feature is used. 

Charge 

services for 

month 

  Performs charging of services for month (only for 

the Tariscope Provider edition). 

Clear charge   Resets subscribers' costs. Applicable when using the 

restriction feature. 

Find 

duplicate 

records 

  Finds and removes duplicate records from a view of 

calls. 

Tools Archive Ctrl+Shift+B 
 

Allows you to archive or delete records from the call 

table. 

Report 

Designer 

  Allows you to start Tariscope Report Designer. 

Tariscope 

Management 

F8 
 

Opens the Tariscope Management tab when you 

can configure the Tariscope parameters. 

Subscriber 

accounting 

F4 
 

Opens the Account tab, which allows you to get 

customer's account state, generate reports for the 

customers, type information about customers’ 

payments. 

Options   Allows you to set the program parameters. 

Windows Lock layout   This item locks the layout in its current position. 

Close Ctrl+F4  Closes the active tab. 

List of 

windows 

  Displays a list of the opened tabs (windows). 

Help Contents F1  Opens the Knowledge base page of the Tariscope 

site. 

Support   Displays contacts for support. 

Activate   Starts the Activation wizard. 

About   Displays information about the program. 

 

 The work in the Tariscope program is executed in views. There are the following types 

of the views: 

• Call views. They display tables with calls data. 

• IP views. They display tables with data about IP traffic. 

• Service views. They display tables with data about services. 

• The Management view. It allows configuring the Tariscope system.  

• The Accounts view. It provides Subscriber Data Management.  

• The Comparison view. It allows comparing results of the Tariscope call rating with 

results call rating of telecom service provider. 

• The Welcome view. It displays a list of links and news about the Tariscope system. 

• The File view. It allows editing an external file. 

• A view that contains a list of call, IP traffic and service views that were saved in the 

system. 

• A view that contains a list of filters that were saved in the system. 

• Report views. These views contain the Tariscope reports. 

• The Output view. It contains the program log. 
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• The Search view. It contains a list of row numbers that satisfy conditions of the search. 

• Several working views: to parsing CDR, call rating and so on. 

 

You can place these views in any order on the program window. To do this, set focus on 

the header of a view, press the left mouse button, drag and drop the view in the desired place 

of the program. An example of location of the views is shown in Figure 3.4.3. 

 

 
Figure 3.4.3 

 

This feature can be useful in the following cases:  

• for comparison of data from two views or reports;  

• for simultaneous monitoring of the various data sources;  

• for simultaneous opening of a subscriber (customer) account and his call information, 

• and in other cases.  

 

In fact, you have a dashboard. This is especially effective when working on a big 

screen. The Tariscope user can determine the number, location, and size of the views 

displayed on the screen. 

  The views, where the lists of views and filters are displayed, can be located outside of 

the program window. 

  The first view, which the Tariscope user sees after the program start, is the Welcome 

view. An example of this view is shown in Figure 3.4.4. 

  It displays a list of links providing a quick access to a desired operating mode and the 

Tariscope news. 
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Figure 3.4.4 

 

On the left side of the Welcome view the three sections are displayed: 

• Start. It contains links to quickly select the desired mode. 

• License info. It displays information about the Tariscope license. 

• Recent documents. This section contains a list of the recent Tariscope documents. 

 

The Start section contains the following links: 

• Connect / Disconnect. Provides a connection to the Tariscope server or disconnection 

from it. 

• Administration. The link opens the Management view where you can configure and 

manage Tariscope. 

• New view. The link allows opening a new view with information about calls, IP traffic 

or services. 

• New report. The link allows generating a new report. 

• About. Displays information about the Tariscope program. 

 

The License info section displays: 

• Serial number of the license. 

• Subscription to. Displays the last date of the warranty support period. 

• The number of Tariscope version and availability of a new Tariscope version. 

 

The Recent documents section contains also two check boxes: 

• Show page on startup. If you wish the Welcome view appears at startup, select this 

check box. 

• Hide when connected to Tariscope server. To hide the Welcome view, when the 

program is connected to the Tariscope server, select this check box. 
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In the right part of the Welcome view, a brief summary of the latest news contained 

on the Tariscope site is displayed. This allows the Tariscope user to be always aware of the 

latest developments related to Tariscope. The news is divided on categories: articles, releases, 

and all. To select the desired category to displaying only it in the view, click on the icon 

located on the right-top corner of the view and select the category. 

  The Tariscope program allows to the users to have a feedback. To provide a feedback, 

click on the Feedback icon located in the top right corner of the program (Figure 3.4.2). The 

Feedback window appears as shown in Figure 3.4.5. 

 

 
Figure 3.4.5 

 

Type a name of your problem in the Tell us about the problem box. 

Describe the problem in the Message box. 

In the Area list, select an area related to your problem. 

In the Email box, specify your email address. 

When the Feedback window is opened, Tariscope creates a screenshot. To send the 

screenshot, select the Send screenshot check box. By default, the check box is selected. 

If you wish to add some information, click on the Attach file button and select the required 

file that contains this information. 

Click OK, to send your message. 

 

3.5 Working with views for calls 

 

 Mainly the Tariscope users work with views for calls.  A view for calls is a tab of the 

Tariscope program, in which the call data are displayed in the table form. Usually one table 



 

Tariscope 4.x. User's guide                                                                                                              16 

row corresponds to one call. For calls where a call transfer or conference were used, the call 

information can be contained in multiple table rows. Each view can have own parameters 

such as: 

• Filtering parameters. They provide a display of only specific records, for example, 

the calls of only a specific subscriber, group of subscribers, calls during a specific 

period, etc.  

• Sorting parameters. They allow to sort information in the table using one or a group 

of fields. 

• Fields of the view. A user can set a list of fields, which will be displayed in the view. 

• Bookmarks. You can set bookmarks for further fast search of necessary records. 

• Colorizing records. You can set the color for specific records, in which they are 

displayed in the table. It allows you to quickly find required records. 

• Data grouping. Data of a view for calls can be grouped according to some of the fields 

that allows you to quickly create summary reports. 

 

3.5.1 Creating and saving a view for calls 

 

 If you have already started the process of collecting data about the calls and you want 

to analyze the data, create a new view for calls.  

 To do this, in the program menu, select Data → New data view, or click on the New 

view icon on the toolbar. The Filter window appears as shown in Figure 3.5.1.  

 

 
Figure 3.5.1 

 

This window allows you to set the filter conditions before opening the view. The 

window allows you to specify complex filter conditions on a group of parameters, such as:  
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a subscriber name, name of a subscriber group, telephone system, subscriber phone number, 

call destination, call type, time period, and others. 

In this section, we will not consider filtering options in detail. They will be considered 

in the following sections.  

At the same time, we note that a telephone system and time period are frequently 

selected when creating a new view.  

At first, if you wish to create a view for calls, keep the Calls item in the View type list. 

To select a telephone system, click on the ‘…’ button located on the right from the 

Node/Equipment box. The Equipment selection window appears where all 

telecommunications nodes and all telephone systems are displayed. Select the desired items 

and click OK.  

To select a time period, click on the Period list and choose a desired item.  

To apply the filter conditions, click OK in the Filter window. 

 

You may skip the Filter window by clicking on the OK button (Figure 3.5.1). If 

necessary, you can specify the filter conditions later. However, if you plan to set any filter 

conditions in the view, we recommend to set them at this stage, since filtering reduces the 

number of records displayed, and thus speeds up the process displaying them.  

 

 After you have set the filter parameters, click OK. A new view will be created for 

which the system assigns a name, for example: View1, if it is a first view. You can replace 

this name by any other name. To do this, right-click on the view name. In the appeared menu, 

select the Rename item. Type a new name. 

 You can create a next new view with another filter parameters and so on. 

 

 All views are automatically saved by the system. But if after creating the view, you 

have made some changes in it, saving these changes will depend on the program settings. To 

check the program settings, select in the program menu: Tools → Options. The Options 

window opens as shown in Figure 3.5.2. 

 

 
Figure 3.5.2 

 

To automatically save changes in a view, select the Automatically save documents 



 

Tariscope 4.x. User's guide                                                                                                              18 

check box, and click OK.  

  

 

3.5.2 Management of the views 

   

 The Tariscope program allows you to manage the Tariscope views. In the Tariscope 

menu, select View → Data views or click on the Views icon on the toolbar. The Views view 

appears that contains a list of the built-in views and views created by the Tariscope users. An 

example of the view is shown in Figure 3.5.3. 

 

 
Figure 3.5.3 

 

The view contains a list of views for calls, IP traffic, and services. A view type is 

displayed in the Type column. The view also contains the following columns: 

• View. Displays a folder name or view name. 

• Changed. Displays the date and time when a view was changed. 

• Owner. Displays a user name who created or changed a view. 

• Sort fields. Displays a list of fields that are used to sort data in the view. 

• Coloring. Displays the conditions of coloring in the view. 

• Group by fields. If grouping is applied in the view, the column displays a field that is 

used for grouping. 

• Bookmark count. Displays a number of bookmarks that the view contains. 

• Field count. Displays a number of fields that the view displays. 

• Main filter. Displays the main filter that is applied to the view. 

• Filter. Displays the additional conditions of filtering that are applied to the view. 

 

By default, the view displays the following columns: Type, View, Changed, Owner. 
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Views can be grouped in folders. The folders may contain subfolders. You can drag 

and drop any view from one folder to another folder. Tariscope includes the Built-in folder 

that contains a list of widely used views. 

 To open any view, double-click on the view name, or select the view, and click on the 

Open view icon on the toolbar. 

 To create a new view, click on the New view icon on the toolbar. The Filter window 

opens as shown in Figure 3.5.1. Specify the filter conditions for the new view and click OK.  

 You can edit all view parameters. To do this, select a desired view, and click on the 

Edit view icon on the toolbar. The View configuration window appears as shown in Figure 

3.5.4. 

 
Figure 3.5.4 

 

 The window contains a list of view parameters. To edit the required view parameter, 

click on the appropriate Edit link. The special window will be opened where you should 

make changes. 

 If you have opened view and want to quickly find it in the view list, for example, to 

change its parameters, click on the Select view icon on the toolbar. The focus will be set on 

this view name. 

 To rename the view, select the desired view, and click on the Rename icon on the 

toolbar. Type a new name. 

 To delete a view, select the view, and click on the Remove icon on the toolbar. In the 

window that appears, confirm deleting the view. 

 There are two pop-up menu in the Views view. The first menu appears when you right-

click on the header of the table. The menu contains the following items: 

• Filtering. When you select this item, the submenu appears that contains a list of views. 

Select the required views. 
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• A list of the columns. Select or clear desired columns. 

 

The second menu appears when you right-click in any place of the table except of the 

header. This menu contains the following items: 

• Open. Opens the selected view. 

• Refresh. Refreshes information about views. 

• Add view. Allows adding a new view. 

• Edit view. Allows you to edit parameters of a selected view. 

• Add folder. Allows creating a new folder for views. 

• Rename. Allows you to rename a selected view. 

• Delete. Allows you to delete a selected view. 

• Export to Excel. Exports information about views to the Excel format. 

• Export to HTML. Exports information about views to the HTML format. 

• Export to CSV. Exports information about views to the CSV format. 

• Export to PDF. Exports information about views to the PDF format. 

 

To quickly find a desired view in the list, type the view name in the search box. 

 

 

 

3.5.3 Fields of a view for calls 

 

 A view for calls contains a list of fields, which can be displayed or hidden in the header 

of calls table. A list of all fields and their brief description are shown in Table 3.2. 

 

Table 3.2 

Field 

name 
Description 

Access code 
Displays an access code, CDP steering code or trunk access code depending on the 

PBX and the route selection. 

Auth code Displays an authorization code which was used to make this call. 

Call second Displays a call duration expressed in seconds. 

Call type Displays call types that are listed in the Table 3.4. 

Called party 
Displays a subscriber's name who received a call, if information about the subscriber 

has been entered in Tariscope. 

Calling party 
Displays a subscriber's name who made a call, if information about this subscriber has 

been entered in Tariscope. 

Category 
Displays a category name which the Tariscope administrator has defined for the spe-

cific call type. 

CLID 
CLID means Calling Line Identification. It displays the telephone number of a sub-

scriber who made the call. 

Cost Displays a call cost. 
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Cost 2 Displays a call cost, which is calculated using the rate of the secondary provider. 

Date 
Displays a date of beginning of the call. If the information on year is missing in CDR 

data, the year is taken from the current date of the computer. 

Date/time 
Displays a date and time of beginning of the call. If the information on year is missing 

in CDR data, the year is taken from the current date of the computer. 

Days Displays a part of the total call duration in days. 

Dial number 
Displays the dialed number with access code, or without it, depending on whether it is 
present, and information about it has been entered when configuring routes in Tari-

scope. 

Direction Displays a direction of the call. For example: Outgoing, incoming, or internal. 

DNIS 
DNIS means Dial Number Identification. The field is present only for incoming calls. It 

displays the dialed number. 

Duration Displays a call duration. 

End of calls Displays a date and time of end of the call. 

Equipment Displays an equipment name. 

From desti-

nation 

For incoming, transit long distance, or international calls, this field displays a city name 

from which call was made. For incoming or transit calls from network of mobile opera-

tor this field displays a mobile operator name. 

From group 
This field is applied only for outgoing or local calls. It displays a subscriber group 

name to which a subscriber who made the call belongs. 

From sub-

scriber 
Displays a subscriber’s name who made the call. 

Hold time Displays a time when the call was on hold. 

ID Displays an identifier of the record. 

Node Displays a node name. 

Number A Displays a telephone number from which the call was made. 

Number B Displays a telephone number on which the call was made. 

Originator 

Depending on call type (internal, outgoing, incoming, conference, or transit), this field 

may contain a directory number of subscriber or number of attendant console from 

which the call was made, route number and trunk from which call was received, the 

conference number. A route number and trunk are shown in the form of: Lxxxyyyy, 

where L - sign of route / trunk, xxx - route number, yyy - trunk number in the route. 

Originator 

Aux. ID 

The field contains an additional information that allows defining an originator of the 

call. 

Original 

CLID 

CLID means Calling Line Identification. The field displays the telephone number of a 

subscriber who made call in those form as it was in the original call detail record. 

Original di-

aled number 
Displays the original dialed number that was in the original call detail record. 

Parent call 

ID 

If this record is a part of call such as a Call Transfer or Conference, the field displays 

ID of the parent record for this call. 

Project code Displays a project code which has been applied during the call. 
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Rate Displays a rate value that has been used to calculate the cost of the call. 

Record Displays a record type. A list of record types you can see in the Table 3.3. 

Release 

cause 
Displays a description of Call Termination Cause. 

Ring time Displays a ringing time for incoming calls. 

Terminator 

Depending on call type (internal, outgoing, incoming, conference, or transit), this field 

may contain a directory number of subscriber or number of attendant console where the 

call was made, route number and trunk through which the call was made, or conference 

number. A route number and trunk are shown in the form of: Lxxxyyyy, where L - sign 

of route / trunk, xxx – a route number, yyy – a trunk number in the route. 

Terminator 

Aux. ID 

The field contains an additional information that allows defining a terminator of the 

call. 

Time Displays a time of beginning of the call. 

To destina-

tion 
The fields is applied to outgoing calls. It displays a city name where the call was made. 

To group 
This field is applied only for incoming or local calls. It displays a group name to which 

a subscriber who received the call belongs. 

 

 

A list of record types, which are used in the Tariscope system, and their descriptions 

are shown in Table 3.3. 

 

Table 3.3 

Record type Description 

ACD   The type is assigned to calls which were received by Automatic Call Distribution 

system. 

ACDConference The type is assigned to calls which were received by Automatic Call Distribution 

system and included in conference. 

ACDTransfer The type is assigned to calls which were received by Automatic Call Distribution 

system and transferred to another subscriber. 

Conference   The type is assigned to the conference calls. 

Imported   The type is assigned to calls that were imported in the Tariscope database from 

data of a service provider. 

NotAnswered The type is assigned to the outgoing, incoming, and internal calls which were not 

answered. 

Realtime   The type is assigned to calls for which call information was received in the real 

time. Usually it is a beginning of call, a moment when call was answered, etc. 

Regular The type is assigned to outgoing, incoming, and internal calls that were answered. 

TextMessage The type is assigned to calls where text messages are passed. 

Transfer The type is assigned to calls for which the call transfer was applied. 

Unknown The type is assigned to calls that do not belong to other record types. 
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VoIP The type is assigned to VoIP calls, if CDR data contains a special label for such 

calls. 

 

A list of call types, which are used in the Tariscope system, are shown in Table 3.4. 

 

Table 3.4 

Call type Description 

CallStart The type is assigned to the first part of a call that is monitored in the real 

time. 

Corporate The type is assigned to calls that are made between different telephone 

systems of a corporation. 

Incoming The type is assigned to incoming calls. 

International The type is assigned to outgoing international calls. 

Internal The type is assigned to internal calls. 

Local The type is assigned to local calls. 

Mobile The type is assigned to outgoing calls on telephone numbers of a mobile 

network operator.  

MMS The type is assigned to calls that are used to transfer MMS. 

National The type is assigned to outgoing long distance calls. 

NotOverride The type is assigned to calls that were imported and which cannot be 

changed.  

SMS The type is assigned to calls that are used to transfer SMS. 

Transit The type is assigned to transit calls. 

Unknown The type is assigned to calls that do not belong to other call types. 

 
 

 Tariscope user can analyze only those fields in the program which are necessary in the 

current moment. 

 To hide unnecessary fields, move the cursor on the title of the required column and 

right-click. The menu appears where you should select the Hide field item. 

 To display previously hidden field, move the cursor anywhere on the title of the table 

and right-click. The menu appears. Select the Select fields item. The Select fields window 

appears which contains all the fields listed in Table 3.2. An example of the window is shown 

in Figure 3.5.5. 

Select the desired check boxes from the list. Accordingly, to hide a field, clear its check 

box. In this window you can also change the display order of fields by using buttons located 

on the right of the window. Click OK. 

 You can change the order of the fields directly in the table. To do this, move cursor to 

a column header, click and hold the left mouse button, drag the column to a desired position. 

Then release the mouse button. 
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Figure 3.5.5 

 

 Tariscope can save all CDR data for some telephone systems such as Cisco Unified 

Communications Manager (CUCM), Cisco CallManager Express (CME), CS 1000, and 

Meridian 1 (Avaya, Nortel). All CDR fields for these PBXs are save in the special tables of 

the Tariscope database. To get information about all CDR fields, select a desired record or 

group of records in the Tariscope view, and right-click. In the appeared menu, select the 

Record details item. As a result, information about all CDR fields is displayed in the Call 

details view. An example of the window is shown in Figure 3.5.6. 

 

 
Figure 3.5.6 

  

 The column names of the window are the same as a vendor uses in CDR. 

 

3.5.4. Fields of a view for services 

 

A view for services is created the same way as a view for calls. You should select in 

the menu: Data -> New data view. The Filter view appears as shown in Figure 3.5.1 where 

in the View type list, select the Services item. The view for services is opened. It contains a 
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list of all services that were set in the system. Usually, this view is useful only for users of 

the Tariscope Provider edition. The table of the view contains columns where information 

about the fields that are listed in Table 3.5. 
 

Table 3.5 

Field Description 

Bank authority A bank name which is used to payments for the service. 

Charge A value of charge for the provided service. 

Description A description of the service. 

Equipment An equipment name where the subscriber is served.  

From date A date from which the service is charged to the subscriber. 

ID An identifier of the current record. 

ID2 An identifier of the current service in the subscriber database. 

Node A telecommunication node to which the subscriber belongs. 

Number Subscriber’s DN. 

Payment A value of the payment for the service. 

Record date The date of the current record. 

Service code A code that was assigned to this service. 

Service ID An identifier of the service in the service list. 

Service name A name of the service. 

Service period The period when the service was provided. 

Service usage 

count 

For the service such as calls of a specific type this field displays number of seconds 

for the service period. 

Subscriber ID An identifier of subscriber for which the service was provided. 

Subscriber 

name 

A subscriber name. 

To date The date before which the service was provided. 

 

A view for services has the same features to work with the fields as a view for calls. 

To specify a list of the fields to display, right-click on the header of the table. The Select 

fields window appears as shown in Figure 3.5.7. 

 

Figure 3.5.7 



 

Tariscope 4.x. User's guide                                                                                                              26 

3.5.5 Fields of a view for IP traffic 

 Tariscope provides a collection of information about IP traffic from network devices 

which support NetFlow, IPFIX, or rFlow. To analyze this information, the view for IP 

traffic is used. A view for IP traffic is created the same way as a view for calls. You should 

select in the menu: Data → New data view. The Filter view appears as shown in Figure 

3.5.1 where in the View type list, select the IPv4 Traffic item, and click OK. The view for 

IP traffic appears. A list of fields of the view is shown in Table 3.6. 

Table 3.6 

Field Description 

Date/time Displays a date and time of the beginning of IP session. 

Destination Displays an IP address of IP traffic destination. 

Destination port Displays an IP port of the IP traffic destination. 

Equipment Displays an IP device name from which IP traffic was collected. 

ID Displays an identifier of the record.  

Protocol Displays an IP protocol that was used for this IP session. 

Session duration Displays a session duration. 

Source IP Displays an IP port of the IP traffic source. 

Source port Displays an IP port of the IP traffic source. 

 

A view for IP traffic has the same features to work with the fields as a view for calls. 

To specify a list of the fields to display, right-click on the header of the table. The Select 

fields window appears as shown in Figure 3.5.8. 

Figure 3.5.8 
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3.5.6 Search of information in a view. Bookmarks 

 

 To find a desired information in a view of calls, select in the menu: Edit → Find. The 

Find window appears as shown in Figure 3.5.9. 

 

Figure 3.5.9 

 

 If, before opening the window, the focus was located in a required column, then the 

name of that column will be automatically displayed in the Search in list. In Figure 3.5.6 the 

focus was located in the Call type column. If you want to search for in all columns, select 

the All value in the Search in list. 

 In the Sample box, type a whole value or its part. 

 To search for a value that completely corresponds to the value of the Sample box, 

select the Whole word check box. 

 If you want the search to be case sensitive, select the Match case check box. 

 To execute the search in the reverse direction, select the Reverse direction check box. 

 Click Next, if you wish to find the first value that corresponds to the desired value.  

 If you wish to get all records that contains the desired value, click on the right part of 

the Next button, and in the appeared menu, select the All item. The Search view appears 

where the results of the search will be displayed. An example of the Search view is shown 

in Figure 3.5.10. 

 

Figure 3.5.10 

  

 There are three columns in the Search view: 
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• Row. Displays the row number, which contains the search result. 

• Column. Displays the column name that contains the search result. 

• Text. Displays the value that corresponds to the search conditions. 

 

 Select a desired result in the Text column and, click on the Show row icon on the 

toolbar of the view or double-click on the selected row. In the view for calls the focus moves 

to the corresponding entry. 

 

 Another option for searching information in the views is a filtering. This feature allows 

you to select only those records of calls that meet the conditions of the filtering. It is the most 

powerful search engine, which searches for on various combinations of view fields. The 

filtering is discussed in the next section.   

 

 If you know a line number of a desired record, this information displays on the right 

side of the bottom line of the program window, then to move to the line, select in the program 

menu: Edit → Go to. The Go to window appears. Enter the line number and click OK. Focus 

will move to the desired line. 

 

 

Bookmarks 

 

 If you have found the required row in the table of calls, you can set a bookmark on this 

row for a quick search of this row in future. To set bookmark on a row, select the row. In the 

program menu, select: Edit → Bookmark. Or, right-click and in the appeared menu, select 

the Bookmark item. The font color for this row will become blue. 

 

 Searching for a desired bookmark can be done in two ways: 

• Right-click anywhere in the table and in the appeared menu, select the Next book-

mark or Previous bookmark item. 

• In the program menu, select: Edit → Next bookmark or Previous bookmark. 

 

 To delete a bookmark, move to this row, right-click and in the appeared menu, select 

the Bookmark item.  

 To delete all bookmarks, select in the program menu: Edit → Clear bookmarks. 

 

 

3.5.7 Data filtering 

 

 The Tariscope program offers you several options of data filtering: 

• an inclusion or exclusion of call records that contain the selected cell of the table; 

• a creation of filter conditions using the advanced filter; 

• a creation of filter conditions using SQL query; 

• a creation of filter conditions using all mentioned above options. 



 

Tariscope 4.x. User's guide                                                                                                                      29 

The detailed description of various options of filtering data is considered in the following 

sections. 

 

 

3.5.8 Filter by selection and Exclude selection 

 

 The simplest way to filter the information in a view for calls is a selection of records 

that have the same value in a column or exclusion of records that have the same value in a 

column. 

 To select records with the same value in a column: 

• find, for example, using the search feature, the table cell that contains the required 

information; 

• right-click and in the appeared menu, select the Filter by selection item. 

 

As a result, the view will contain only those records of calls where values are the same 

as in the selected cell. 

 You can repeat these actions by applying them to the different columns of the view.

 If you want to return the table of calls to its previous state, on the toolbar, click the 

Previous filter icon or, select the menu: Filter → Previous filter. The view returns its 

previous state. 

 In order to exclude records that have the same value in a column of the table: 

• find, for example, using the search feature, the table cell that contains the required 

information; 

• right-click and in the appeared menu, select the Exclude selection item. 

 

As a result, all records, which had the same value as the selected value, will be 

excluded. 

To return the table of calls to its previous state, on the toolbar, click the Previous filter 

icon. 

 The main advantage of this filtering method is an ability to quickly apply a filter 

condition. The disadvantage is a complexity in creating complex filtering conditions. 

 

3.5.9 Advanced filter 

 

 The next filtering feature with increasing opportunities of filtering than features 

discussed in the previous section, is the advanced filter. To use this feature, click on the Filter 

icon on the toolbar, or select the menu: Filter → Filter. The Filter window appears, as shown 

in Figure 3.5.11. This window appears also when you create a new view. 

 If you create a new view, the Filter window provides a choice of a view type:  

• for calls,  

• for services, 

• for IP traffic. 

To select a view type, in the View type list, select a desired option.  
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If you apply this filter to a specific view, the View type list is inactive. 

 If Tariscope is used for multiple telecommunications nodes or multiple telephone 

systems, to select records for a desired node or telephone system, click on the "..." button 

located on the right of the Node/Equipment box. As a result, the Equipment selection 

window appears, the example of which is shown in Figure 3.5.12. 

 In the window, select the check boxes of nodes or telephone systems which you want 

to filter out, and click OK. 

 If necessary to quickly clear all selected check boxes in the window, click on the 

Uncheck all link. 

 

 
Figure 3.5.11 

 

 
Figure 3.5.12 

 

 In the Filter window (Figure 3.5.11) in the Period list, select a time period, if you 

wish to filter out calls during a specific time period. The Period list contains the following 

options: 
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• No filter. 

• Today. 

• Yesterday. 

• This week. 

• Previous week. 

• This month. 

• Previous month. 

• This year. 

• Previous year. 

• Custom month. 

• Custom year. 

• Custom period. 

 

 When you select the Custom month option, two additional lists appear in the Filter 

window: Year and Month which are used for selection of a desired month. 

 When you select the Custom year option, the Year list appears in the Filter window, 

where you must specify a desired year. 

 When you select the Custom period option, the From and To calendar list appear in 

the Filter window. You should specify dates and times which are the beginning of the 

filtering period and the end of the filtering period. You can specify values only for one of 

these lists. If you have set values for the From list, Tariscope will filter out data from the 

specified date and time till the current moment.  If you have set values for the To list, 

Tariscope will filter out data from the first date in the database till the specified date and time. 

 

 On the General tab of the Filter window you can set the following filter conditions. 

 The Source list allows to select an originator of calls. The list contains the following 

parameters: 

• Auto. 

• Extension. 

• External number. 

• Subscriber. 

• Group. 

• Route, trunk, gateway. 

• List. 

Let's look at each of these parameters. 

 Auto. Type the desired value in the box located on the right from the Source list.  The 

system will automatically find all combinations of the entered characters, which can be in a 

subscriber’s name or description of the area codes. The result of the search will be displayed 

in a list. The example of this is shown in Figure 3.5.13. 

As you see in Figure 3.5.13, the "Sm" characters were entered. As a result, the system 

displays a list of data where "sm" characters are found. Then you can select a desired value 

from the list or continue the input to decrease a number of items in the list. 
 



 

Tariscope 4.x. User's guide                                                                                                              32 

Figure 3.5.13 

  

Extension. This choice allows you to find the call initiator using his phone number 

(extension). If you start entering digits, for example, "333", then a list of subscribers or area 

codes appear where this combination of digits are found. An example of this is shown in 

Figure 3.5.14. 

Figure 3.5.14 

 

Then you can select a desired value from the list or continue the input to decrease a number 

of items the list. 

If in the Source list you have selected the Extension item, you can also click on the "..." 

button located on the right from the list. The Choose subscriber window appears. An 

example of the window is shown in Figure 3.5.15. 

 

 
Figure 3.5.15 
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 This window has a number of features to the search of the desired subscriber. 

 Firstly, you can find a desired subscriber visually scrolling through the list. 

 Secondly, you can enter a desired parameter, such as a telephone number or name of a 

subscriber in the search bar. As a result, in the Choose subscriber window will be displayed 

records that match the search criteria. An example of such results is shown in Figure 3.5.16. 

 

 
Figure 3.5.16 

 

 Thirdly, you can use a filtration in this window. To do this: 

• Determine a column by the value of which filtering will be performed. For example, 

let it be the Full name column. 

• Right-click on the header of this column. Menu appears as shown in Figure 3.5.17. 

• Click on the Filtering item. A submenu appears, an example of which is shown in 

Figure 3.5.18. Note that this submenu is different depending on which column is used 

and from the values of this column. This submenu contains items that are one or the 

first few characters of the column values. 

• Select required items in the submenu and click Apply. 

 

Figure 3.5.17 

 

As a result, records will be selected, which match to filter conditions, in the Choose 

subscriber window. From these records, select a desired record and click OK. 

External number. This choice means that incoming calls made from this external 

number will be selected. In the Source box, type a desired external telephone number. You 

can specify the search on the part of the telephone number. For example, external phone 

numbers of calls from Kiev to subscribers of your telephone system located in Ukraine begin 

from 044 in the Tariscope database. Therefore, to search all incoming calls from Kiev, type: 

044%, where % is a sign of the template. 
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Figure 3.5.18 

 

 Subscriber. This choice means that a search of calls that has made by a specific 

subscriber will be performed. An input or selection of a desired subscriber is completely 

analogous to that described for the Extension option. 

 

 Group.  This choice means that a search of calls that have made by subscribers of a 

specific group will be performed. As described above, you can specify a desired group using 

an input of a group name or choice of the group in the Select group window shown in Figure 

3.5.19. The choice of a desired group in this window is similar to a search of subscriber in 

the Choose subscriber window, which is described above. 

 

Figure 3.5.19 

 

 Route, trunk, gateway.  This choice means that it will be performed a search for 

incoming calls that have been received through a specific gateway, route, or trunk. To search 

a desired gateway, route, or trunk, type its name in the Source box, or click on the "…" button 

and, select a desired value in the Choose gateways and trunks window. 

 

 List. This choice means that it will be performed a search for calls that have been made 

from telephone numbers that belong to this list and values of which are located in the 

Number A column of the table of calls. Type the list of telephone numbers separated by 

commas. For example, to search calls made from extensions 4000, 4005, and 0441234567, 

type: 4000,4005,0441234567. 
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 The Destination list of the General tab (Figure 3.5.11) allows you to select a call 

terminator. An input of parameters, its choice is completely analogous to that is described for 

the Source position. 

 If you need a search for calls with a specific call originator and call terminator, you 

can combine the Source and Destination positions using one of the logical operations: AND, 

OR. An example of such filter settings is shown in Figure 3.5.20. 

Figure 3.5.20 

 

 If you select the AND operator for this example, the filtering conditions will mean that 

all calls made from the extension of 2259 to London will be selected. 

 If you select the OR operator for this example, the filtering conditions will mean that 

calls made from the extension of 2259 or calls made to London will be selected. 

 

 The From place (city) box of the General tab (Figure 3.5.11) allows you to find 

incoming calls made from a specific place (city) or from telephone numbers of specific 

mobile provider. Type a desired city name in the box. You can type a template. To specify a 

template, use the percentage symbol (%). For example, you are interested in all incoming 

calls made from the New York region. If the Tariscope database contains the city names for 

these area codes, then you should type: %New York% 

 

 The To place (city) box of the General tab (Figure 3.5.11) allows you to find outgoing 

calls made to subscribers in a specific city or to telephone numbers of a specific mobile 

provider. Type a desired city name in the box. You can type a template. To specify a template, 

use the percentage symbol (%). For example, you are interested in all long-distance calls 

made to Germany. If the Tariscope database contains the name of this country, you can type 

the following template: %Germany% 

 

 The General tab contains also the Call attributes section that allows you to specify 

the following parameters for search of calls:    

• Call direction. 

• Call type. 

• Record type. 

• Terminate reason. 

 

 The Call direction parameter provides a search of calls made in a certain direction. To 

set a value of this parameter, click the "..." button that leads to appearance of the Choose 

items window shown in Figure 3.5.21. 

 In the window, select check boxes for those directions that are of interest, and click 

OK. If you need all items, click the Check all link. If the call direction is not specified, it is 

assumed that all destinations are selected. 
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 To quickly clean of all selected items, click on the Uncheck All link. 

 

 
Figure 3.5.21 

 

 The Call type parameter allows you to select records only with specific call types. To 

select the call types, click on the "…" button. The Choose items window appears as shown 

in Figure 3.5.22. 

 
Figure 3.5.22 

 

 In the window, select check boxes for those call types that are of interest, and click 

OK. If you need all items, click the Check all link. If the Call type parameter is not specified, 

it is assumed that all call types are selected. 

 

 The Record type parameter allows you to select records only for specific record types. 

To select the record types, click on the "…" button. The Choose items window appears as 

shown in Figure 3.5.23. 

 In the window, select check boxes for those record types that are of interest, and click 

OK. If you need all items, click the Check all link. If the Record type parameter is not 

specified, it is assumed that all record types are selected. 
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Figure 3.5.23 

 

 The Terminate reason parameter allows you to select only those calls which were 

completed with a specific termination code. To choose the desired codes, click on the "…" 

button located on the right from the Terminate reason box. The Choose items window 

appears as shown in Figure 3.5.24. 

 

 
Figure 3.5.24 

 

 In the window, select check boxes with desired termination codes, and click OK. If 

you need all items, click the Check all link. If the Terminate reason parameter is not 

specified, it is assumed that all terminate reasons are selected. 

  

 Besides the main filtering options, the Filter window allows you to specify a number 

of additional parameters. To do this, select the Advanced tab. The Filter window will be as 

shown in Figure 3.5.25. The tab allows you to set the following filter parameters: 

• Auth code. You can specify an authentication code if it was used. 

• Project code. You can set this parameter if it is used and consisted in CDR data. 
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• Category. You can filter out records on the category names if they were entered in 

Tariscope. 

• Cost from … to. These parameters allow specifying a range of call costs. 

• Day type. Defines a day type when call was made: Workday, Holiday, Saturday, 

Sunday. 

• Time of day. The parameter allows specifying a time period during which the calls 

should be selected. 

• Duration. Defines a time range of a call duration. 

• TTA. (Time To Answer). TTA is a time period when the ring tone sounds. You can set 

these parameters in case if your telephone system generates such information. 

 

 
Figure 3.5.25 

 

 Type the desired values in the following boxes: Auth code, Project code, Cost. 

 Selection of the filtering parameters for the Category and Day type items are 

performed from the additional windows that are invoked by clicking on the "…" buttons 

located on the right of these positions. 

 Selection of time ranges for the Time of day, Duration and TTA items are performed 

by selecting check boxes in a desired position and specifying the desired values. 

 After setting of the filtering parameters on the General and Advanced tabs, draw 

attention on the value of the Combine with list located in the bottom line of the Filter 

window (Figure 3.5.25). 

 By default, the value of the list is empty. This means that as filter conditions are used 

only parameters which was set in the window. The list contains the permanent and custom 

options. The permanent options are following: 

• Base filter of view. These are the base filtering parameters that were set for the current 

view. If you select this item, it means that the filter conditions of the Filter window 

will be combined with the filter conditions of the base filter.  

• Current filter of view. Select this item, if you want to combine the current filter 

conditions of the view with the filter conditions of the Filter window. 
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If you have saved filters in Tariscope, they and pre-set filters will be displayed in the 

list as custom options. 

If you select any option in the list, the filtering parameters specified in the Filter 

window will be combined with the filtering parameters of the selected option using logical 

operator. By default, the AND operator is set. You can choose other logical operators such 

as: OR, AND NOT. 

 

 To view how looks the SQL query of the Filter window before applying its parameters, 

click on the SQL icon located on the bottom line of the window filter. An example of the 

Filter window after clicking the SQL icon is shown in Figure 3.5.26. 

  

 
Figure 3.5.26 

 

This window displays a portion of the SQL query that is located in a query after the 

WHERE operator. Tariscope defines the syntax of the query and for the convenience it 

displays the various its parts in different colors. 

 In order to return from this form of the Filter window to its normal form, click on 

SQL icon or on the Press here link. 

 You can change the SQL query. But the changes will not be saved, if you return to the 

normal form of the Filter window. 

 

 If you wish to quickly clear all filtering parameters of the Filter window, click on the 

Clear filters icon located on the left part of the bottom line of the window. 

 

 To apply the filter parameters which were set in the Filter window, click OK. As a 

result, the current view will display calls that match the filtering conditions. 

  

 If you wish to cancel the filtering parameters in the view and return the view to the 

state before applying the filter, on the toolbar, click on the Previous filter icon or select in 
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the menu: Filter → Previous filter. If you a few times changed the filter conditions, you can 

change these filter clicking on the icons: Previous filter and Next filter. 

 

 Consider the following example of using of the advanced filter. For example, you need 

to obtain information about all long-distance (national) and international calls of William 

Johnson where the call duration is more than 2 minutes. 

  To do this, we set the following parameters on the General tab of the Filter window: 

• If you remember the phone number of William Johnson, in the Source box when it has 

the Auto option in the list, type the phone number. If you do not remember the phone 

number, in the Source list, select the Subscriber value, click on the "..." button and in 

the Choose subscriber window, select William Johnson, as described above. 

• Click on the "…" button of the Call type position and select values: National and 

International. 

The Filter window will look as shown in Figure 3.5.27. 

 

Figure 3.5.27 

 

Go to the Advanced tab.  

In the Duration from calendar box, specify the duration of calls: 0:02:00. The Filter window 

will be as shown in Figure 3.5.28. 

 Click OK. The filter conditions will be applied. 
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Figure 3.5.28 

  

 

3.5.10 SQL queries 

 

 The most powerful tool in Tariscope for creating the filtering conditions is SQL queries. 

To create them in the Tariscope program, use the SQL filter mode which is accessible from 

the Filter menu or by clicking the SQL filter icon on the toolbar. After selecting this option, 

the View filer window appears, an example of which is shown in Figure 3.5.29. 

  

 
Figure 3.5.29 

 

 The SQL filter allows you to set an arbitrarily complex filtering settings for any fields 

of the call database. We recommend using this filtering method, if you cannot create a desired 

filter using the advanced filter, or for you is easier to write a SQL query, rather than to select 

the desired parameters in a graphical form. As a rule, the creating of SQL queries requires 

the knowledge of SQL language. But a new interface of the window allows building a huge 

number of such queries almost without any knowledge of the SQL language. 
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 The View filter window (Figure 3.5.29) is divided on two parts. The top part provides 

a creation of a SQL query by selecting a desired field and operator and typing a desired value. 

The resulting partition of a SQL query that is contained after the WHERE operator is 

displayed in the bottom part (the Query box) of the window. If you well know the SQL 

queries, you can write a SQL query at once in the bottom part of the window.  

If a view does not contain any filter conditions, the View filter window will be as 

shown in Figure 3.5.30. 

 

 
Figure 3.5.30 

 

To add a filter condition, click on the “+” button in the window. A new row appears in 

the window as shown in Figure 3.5.31. 

 

 
Figure 3.5.31 

 

The row consists of three parts. In left part a field of the call database is selected. The 

middle part provides a selection of an operator. In the right part it should type a value for the 

filter condition.  

Double-click on the left part of the row. The list of the fields appears. Select a desired 

field. A list of the fields and their descriptions, see in Table 3.2. 

Click on the middle part of the row. The menu appears that contains possible operators 

for a SQL query. Select a desired operator. A list of possible operators is shown in Table 3.7. 
 

Table 3.7 
Operator Function Result of query Example of using 

= Equals Returns all records where value of field is equal to a 

particular set of characters entered after the operator 

Calls from subscriber with 

the direct number 347: 

[Originator] = '347' 

<> Does not 

equals 

Returns all records where value of field is not equal to 

a particular set of characters entered after the operator 

Calls with cost is not equal 0:   

[Cost] <> 0 
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< Is less than Returns all records where value of field is less than 

value entered after operator 

Calls with duration less than 

10 seconds: 

[CallSeconds] <10 

<= Is less than 

or equal to 

Returns all records where value of field is less than or 

equal to the value entered after operator 
Calls with date 09.01.2010 or 

earlier: 

[CallDate] <= '2010-1-9' 

> Is greater 

than 

Returns all records where value of field is more than 

value entered after operator 

Calls with cost more than 5 

euro: 

[Cost] > 5 

>= Is greater 

than or 

equal to 

Returns all records where value of field is more than 

or equal to the value entered after operator 

Calls with cost is equal to 5 

or more: 
[Cost] >= 5 

Like Is like Returns all records where values of fields are like to 

the entered pattern. 

All calls to USA: 
[ToTelephone] LIKE 

'%USA%' 
Not Like Is not like Returns all records where values of fields are not like 

to the entered pattern. 

All calls except calls to the 

India: 
[ToTelephone] NOT LIKE 

'%India%' 
In Is any of Records are filtered out, which correspond to elements 

of a given list 

Long-distance, international 

calls: 

[CallType] IN (4, 5) 

Not In Is none of Returns all records where the value is not equal to any 

values that the list contains. 

Calls from PBXs except PBXs 

with the following identifiers 

33,27: 

NOT ([PBXID] IN (33, 27)) 

Between Is between Returns all records where values of the specific field 

are between two specific values 

Calls for the period from 

09.01.2006 to 31.01.2006: 

[CallDate] BETWEEN 

'2006-1-9' and '2006-1-31' 

Not 

between 

In not 

between 

Returns all records where values of the specific field 

aren’t between two specific values 

Calls for the period except 

from 08.08.2016 to 

17.08.2016: 

[CallDate] >= '20160808' 

AND [CallDate] <= 

'20160817' 

Is null Is blank Returns all records where the field value is null. Calls where the originator of 

calls is null: 

[Originator] IS NULL 

Is not null Is not blank Returns all records where the field value is not null. Calls where the originator of 

calls isn’t null: 

[Originator] IS NOT NULL 

 

Double-click on the right part of the row. Depending on the selected field, the list of 

the possible values appears or the box for entering a desired value appears. Select or type a 

desired value. The bottom part of the window will display the SQL query. 

To add the next filter condition, click on the “+” button in the window. A new row 

appears. Repeat the actions described above.  

The first and second conditions are linked by a logical operator. By default, the AND 

operator is used. To change it, click on it and in the appeared menu, select a desired operator. 

 If you wish you can directly write a SQL query in the bottom part of the window. 
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Consider the example of creating a query. For example, you wish to filter out all 

national (long-distance) or international calls and that are longer than 10 minutes or their cost 

is more than 5 euro. 

 To create this query in the View filter window, click on the And link. In the appeared 

menu, select the Add Group item. The new And link and ‘+’ button appears. Click on the 

second And link and, select Or. Double-click on the left part of the row and in the appeared 

menu, select the Call type item. In the middle part of the row, select the Equals operator. 

Double-click on the right part of the row and, select the National item. In the Query box, 

you can see the following string: 

 

([СallType] = 4) 

 

 To add the filtering condition on international calls in the query, click on the “+” button 

near the Or link. A new row appears. Double-click on the left part of the row and, select the 

Call type item. Select the Equals operator. Double-click on the right part of the row and, 

select the International item. In the Query box, you can see the following string: 

 

([CallType] = 4 OR [CallType] = 5) 

 

 To add the information about call duration, click on the “+” button near the And link. 

A new row appears. Double-click on the left part of the row and, select the Duration item. 

In the middle part of the row, select the Is greater than operator. Click on the <enter value> 

prompt and, type 00:10:00. In the Query box, you can see the following string: 

 

([CallType] = 4 OR [CallType] = 5) AND CallDuration > '00:10:00' 

  

 On the next step we add information about cost of calls. Click on the “+” button near 

the And link. A new row appears. Double-click on the left part of the row and, select the 

Cost item. In the middle part of the row, select the Is greater than operator. Click on the 

<enter value> prompt and, type 5. In the Query box, you can see the following string: 

 

([CallType] = 4 OR [CallType] = 5) AND [CallDuration] > '00:10:00' AND [Cost] > 5 

 

Add the brackets for the expression: [CallDuration] > '00:10:00' AND [Cost] > 5,  

and, change AND to OR. The query will be as shown below: 

 

([CallType] = 4 OR [CallType] = 5) AND ([CallDuration] > '00:10:00' OR [Cost] > 5) 

 

 On the toolbar, click SQL Apply filter, and you will receive the required calls. 

 May be other options for creating the query. The correct query string, which is 

completely analogous to the above, would be: 

 

((CallType = 4 OR CallType = 5) AND CallDuration > '00:10:00') OR ((CallType = 4 OR 

CallType = 5) AND Cost > 5) 
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or 

 

CallType IN (4,5) AND (CallDuration > '00:10:00' OR Cost > 5) 

 

 The last query is the most compact. It uses the IN operator, which in this case means 

that the CallType field includes a list of: 4, which corresponds to national calls, and 5, which 

corresponds to international calls. 
 

 A user, who knows the SQL, has possibility to enter a query in the Query box. 

 To quickly clear all filter conditions in the View filter window, click on the Clear icon 

located on the toolbar. 

 

 If it is assumed that a query has been created in the View filter window can be used in 

the future, save it. To do this, open the View filter window and, click on the Save as icon 

located on the toolbar. 

 To select the previously saved filter, open the View filter window and, click on the 

Open icon located on the toolbar. 
 

 

3.5.11 Filter by related calls 

 

 Tariscope contains a special option of filtering for the related records in a view for 

calls. The related records contain information that relates to one call such as a call transfer, 

conference and so on. One such record displays call data about one stage of such calls. 

 Tariscope allows distinguishing the related records in a view. For this, right-click on 

the call table. In the appeared menu, select the Highlight related records item. When you 

move a focus on one of these records, a background of the records becomes grey. 

 There is a special view where the related records display. To invoke the view, right-

click on the call table and in the appeared menu, select the Show related records item. When 

in the view for calls a focus is located on the related record, all related records are displayed 

in the Related record view. 

 Sometimes it is difficult to find all related records belonging to one call. For this 

purpose, use a filter for the related records. Select a record that belongs to one of stage of a 

call transfer, conference or similar calls and, right-click on the call table. In the appeared 

menu, select the Filter by related calls item. The view for calls will display all related calls 

that belong to the call. 

 

 

3.5.12 Management of the filters 

 

Tariscope has a filter management system that allows you to view existing filters, edit, 

save them, and create new filters. Also Tariscope includes pre-set filters. 

To manage filters, in the menu, select View → Filters. The Filters window appears as 

shown in Figure 3.5.32. 
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Figure 3.5.32 

 

 The Filters window contains a list of filters in a form of a tree, filter conditions of 

selected filter, toolbar and search box. In Figure 3.5.32 the Outgoing for CUCM filter is 

selected. Its filter conditions are displayed in the bottom part of the window. 

 The Built-in filter group contains a list of the most common filters. These filters are 

preinstalled in Tariscope. Click on the ‘+’ near the Built-in group. The window will be as 

shown in Figure 3.5.33. 

 

 
Figure 3.5.33 

We briefly describe these filters. 

Call party unknown. This filter provides a selection of calls where a calling party is 

unknown for all call types. It can be useful to find extensions that are absent in the Tariscope 

database. 

Called subscriber unknown. This filter provides a selection of calls where a called party is 

unknown. It can be useful when you analyze incoming calls to find extensions that are absent 

in the Tariscope database. 

Caller subscriber unknown. This filter provides a selection of calls where a calling party is 

unknown. 
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Calls with project codes. This filter provides a selection of calls where project codes were 

applied. 

Incoming calls. This filter provides a selection of all incoming calls. 

Outgoing and transit calls. This filter provides a selection of all outgoing and transit calls. 

Previous month calls. This filter provides a selection of all calls for the previous month. 

This month calls. The filter provides a selection of all calls for the current month. 

This week calls. The filter provides a selection of all calls for the current week. 

Today calls. The filter provides a selection of all calls that were made today. 

Very expansive calls. The filter provides a selection of all calls which have a cost more than 

50 units where the unit is a unit of the national currency. You can change this value. 

Zero cost calls. The filter provides a selection of all calls which have the zero cost. 

 

 You can apply these filters with any different filter conditions. 

 

 The Filters window has a toolbar that contains the following icons: 

• Apply filter. The icon allows applying a selected filter to a current view. 

• Apply Inverted filter. The icon allows applying an inverted filter. For example, you 

have selected the Zero cost calls filter and, click on this icon leads to applying the 

filter with NO operator. As a result, for this example all calls that have a cost more 

than null will be selected.  

• Sync active filter document. The icon allows you to synchronize the active filter of 

the view with data in the Filter window. 

• Refresh. The icon allows you to refresh data in the window. 

• New. The icon allows you to create a new filter for calls, services or IP traffic using 

SQL queries.  

• Edit. The icon provides editing a selected filter. 

• Rename. The icon allows you to rename a selected filter. 

• Delete. The icon allows you to delete a selected filter. 

• Collapse all. The icon allows you to collapse all branch of the filter tree. 

• Show all. The icon allows you to open all branch of the filter tree. 

 

The filter table of the window contains the following columns: 

• Name. Displays a filter name or group name. 

• Modification date. Displays a date when a filter was modified.  

• Used for view. Displays a type of a view for which a filter is applied. 

• Filter. Displays the filter conditions.  

 

The Tariscope users often need to find data for a specific time period. Table 3.8 

contains a list of such filters. 

 

Table 3.8 

Time period Query 

Current day CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'d',0) AND 

dbo.DateToInterval(GETDATE(),'d',0) 
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Yesterday CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'d',-1) AND 

dbo.DateToInterval(GETDATE(),'d',-1) 

Current week CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'w',0) AND 

dbo.DateToInterval(GETDATE(),'w',0) 

Previous week CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'w',-1) AND 

dbo.DateToInterval(GETDATE(),'w',-1) 

Current month CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'m',0) AND 

dbo.DateToInterval(GETDATE(),'m',0) 

Previous month CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'m',-1) AND 

dbo.DateToInterval(GETDATE(),'m',-1) 

Current year CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'y',0) AND 

dbo.DateToInterval(GETDATE(),'y',0) 

Previous year CallDateTime BETWEEN dbo.DateFromInterval(GETDATE(),'y',-1) AND 

dbo.DateToInterval(GETDATE(),'y',-1) 

Specific month CallDateTime BETWEEN '20131001 00:00:00' AND '20131031 23:59:59' 

Specific year CallDateTime BETWEEN '20130101 00:00:00' AND '20131231 23:59:59' 

Specific period CallDateTime BETWEEN '20131024 16:09:10' AND '20131025 16:09:10' 

 

 Texts of queries for specific time periods (Specific month, Specific year, Specific 

period) in Table 3.8 are specified with particular values, which are displayed in bold. When 

you use these queries with your filter conditions, replace these values to desired values. 

 

3.5.13 SQL queries for any table 

 

 Tariscope provides a possibility to execute a SQL query to any table of the Tariscope 

database. This possibility can be useful, for example, to check a SQL query that is used in a 

Tariscope report form or you have a problem with Tariscope. The feature requires the 

knowledge of the Tariscope database. A description of the database, see in the 'Tariscope 4.x. 

Database schema'. 

To do this, create an empty text file with the ‘sql’ extension. In the Tariscope menu, 

select File → Open file. In a list of file types, select the SQL query (*.sql) option as shown 

in Figure 3.5.34. 

 
 Figure 3.5.34 
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It is very important to set this extension. 

 

Select a desired file. A new view is opened in Tariscope where the contents of the file 

will be displayed. 

Write a desired SQL query or a few SQL queries in the view. 

Select a desired SQL query and, click on the Run icon on the toolbar. An example of 

this is shown in Figure 3.5.35. 

 

 
Figure 3.5.35 

 

 If the SQL query is valid, you get a result that is displayed in the Table tab of the view 

as shown in Figure 3.5.36. 

 

 
Figure 3.5.36 

 

 You can select and copy some cells of the table or the entire table. To do this, select 

desired cells and, right-click. In the appeared menu, select the Copy item. 
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 Also you can export the table contents to a file with the following extensions: PDF, 

CSV, HTML or Excel. Right-click in any place of the table and in the appeared menu, select 

a desired option of an export. 

 The Message tab contains information about an execution of a SQL query. 

If you right-click in the part of the view that contains SQL queries, a menu appears 

that contains the following items: 

• Run. Starts the execution of a selected SQL query.  

• Stop. Stops the execution of a SQL query. 

• Undo. It erases the last change done to the document reverting it to an older state. 

• Redo. It is the opposite of Undo. It reverses the Undo. 

• Cut. Allows you to cut a selected data. 

• Copy. Provides copying data to the clipboard. 

• Paste. Provides pasting data from the clipboard. 

• Select all. Provides a selection of the entire table.  

 

 

3.5.14 Sorting data 

 

 A view for calls provides a possibility to sort the data of a table by one field or by a 

group of fields. 

 To sort the data of a column in the table, select the title of a desired column and, right-

click on it. In the appeared menu, select the Sort ascending or Sort descending, depending 

on how you wish to sort the information. 

 If you need to sort by a number of fields, in the program menu, select Data → Sort, 

or right-click anywhere in the table header and, select Sort. In both cases the Sort window 

appears as shown in Figure 3.5.37. 

 

 
Figure 3.5.37 
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 In the Field description column, select desired fields. Using the "↑" and "↓" buttons, 

set the order of their applying in the direction from top to bottom. 

 If necessary to remove any field from the list, clear the appropriate check box. 

 To apply sorting, click OK. 

 

 In order to remove all sort options, right-click on the header of the table and in the 

appeared menu, double-click on the Field description check box. 

 

3.5.15 Grouping function 

 

 The grouping function allows you to aggregate rows displayed in a view using the 

specified parameters, summing up the data contained in other fields or to perform another 

aggregate function. 

 Aggregate functions can be used to the following actions: 

• To sum data. 

• To calculate a number of items in a group. 

• To define a maximum value in a group. 

• To define a minimum value in a group. 

• To calculate an average value in a group. 

 Thus, in columns that were selected for grouping, you will see the unique data values 

in these columns, for example, types of calls. In all other columns, the sums or values of 

another aggregate function will be displayed, for example, a total duration of calls. That is, 

you can calculate, for example, a total duration of calls for a certain period for each subscriber, 

or the number of calls for each of the categories, etc. You can group data on one or more 

fields. For each of the fields, you can choose an aggregate function separately. 

 The grouping feature is accessible for a view for calls, services or IP traffic. 

 Open or create a desired view in the Tariscope program. Right-click on the table title. 

In the appeared menu, select the Select fields item. 

 Define columns that are necessary in the aggregate report. Take in the mind that the 

more columns you will select, the longer period of the report generation will be. In addition, 

most of the fields does not often make sense in an aggregated form. Therefore, we 

recommend leaving only those columns that are needed you. 

 Then you can go to the grouping. Right-click on the title of a desired column, and in 

the appeared menu, select Group by → By this field. The data will be grouped. 

 To undo the grouping function, right-click on the title of the column and in the 

appeared menu, select the Cancel group by item. 

 

 Consider the example of a rapid creation of a report with using the grouping function. 
 

Example. 

Let’s create a report on the costs of calls of each subscriber for the previous month. 

 

 We open a new view. In the appeared Filter window, we set the following filter options.  

In the Period list, we select the Previous month item. In the Call type box, we select the 
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following types: Local, National, International, Mobile. This example of the Filter 

window is shown in Figure 3.5.38. 

 

 
Figure 3.5.38 

 

Click OK. 

In the view, we choose only two fields for display: From subscriber and Cost as shown in 

Figure 3.5.39. 

 
Figure 3.5.39 

 

Click OK. The view will contain only these two fields. 

Next, we group data by the From subscriber field. For the Cost field the aggregate function 

is used as shown in Figure 3.5.40. 
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Figure 3.5.40 

 

 If necessary, the data in the table can be sorted.   

 The result of grouping can be printed or exported to an external file. 

 

 You can use similar actions to create a wide range of different reports. But it should be 

borne in mind that Tariscope already contains a large number of ready-made forms of reports, 

so you can use these reports instead of the grouping function. 

 In conclusion, the knowledge of the SQL language is not required to use the grouping 

function. However, if you need to create more complex reports, you can use the Report 

Designer program, whose work is based on SQL queries. Therefore, we recall that the 

grouping function corresponds to the next expression of SQL: GROUP BY. 

Aggregate functions used in the grouping function are translated into T-SQL functions: 

• Sum: SUM(), 

• Number of items in a group: COUNT(), 

• Maximum value: MAX(), 

• Minimum value: MIN(), 

• Average value: AVG(). 

 

3.5.16 Printing and exporting data 

 

 A view for calls can be printed or exported into external files. Before printing of a view, 

we recommend previewing it to decide that a print format is satisfied you. If you need to 

change the page parameters, in the program menu, select Tool → Options, select the 

Printing tab. 

To preview data of a view, select the menu: File → Print preview. The Preview view is 

opened. An example of the view is shown in Figure 3.5.41. 
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Figure 3.5.41 

 

 The toolbar of the Preview view contains the following icons: 

• Print. Starts the printing. 

• Print settings. Opens a window to specify printer parameters. 

• Zoom. Allows to increase or decrease the contents of the view. 

• One page. Displays one page in the view. 

• Two pages. Displays two pages in the view. 

• Multiple pages. Displays multiple pages in the view. 

 

 You can print data from the Preview view or you select in the program menu: File → 

Print. 

 

 To export data into an external file, select in the program menu: File → Export and in 

appeared submenu, choose a desired file format. You can use the following formats: 

• Microsoft Excel, 

• CSV, 

• HTML, 

• PDF. 

 Another option to export the information to an external file is: right-click on the table 

and in the appeared menu, select a desired item to export data. 

 

 

3.5.17 Other features of a view for calls 

 

 A Tariscope view for calls has two menus. One of which is called by right-clicking on 

the header of the table (Figure 3.5.42), and another menu is called by right-clicking on any 

place on the table except the header (Figure 3.5.43). 
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Figure 3.5.42 

 

 
Figure 3.5.43 

 

 Most of these menu items were discussed in previous sections. There are the following 

features that these menu and main menu contain but they were not discussed in previous 

sections:  

• Record coloring. 

• Row limit. 

• Copy. 

• Recharge selected records. 

• Delete selected records. 

• Record details. 

• View style. 
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3.5.18 Record coloring 

 

 This feature provides a coloring of rows with calls that match a specific parameter.  

This can be useful for analyzing calls. Individual colors can be set for the text and background. 

 To call this feature, select in the program menu: Data → Coloring, or right-click on 

any place of a view except for the table header and in the appeared menu, select Records 

coloring. As a result, the Coloring window appears as shown in Figure 3.5.44. 

 

 
Figure 3.5.44 

 

 The toolbar of the window contains four icons: 

• Apply, 

• Add, 

• Edit, 

• Delete, 

• Exit. 

 Click on the Add icon to add new conditions for coloring. The window appears as 

shown in Figure 3.5.45. 

 
Figure 3.5.45 

 

  In the Column list, choose a field to which the coloring will be specified. 

 In the Operator list, select an operator which you wish to apply. 

 In the Value box, select or enter a desired value for this condition. 

 Click on the "…" button located right on the Font color box, and select a desired font 

color. If necessary, perform a similar action for the Background color box. 

 Click OK. In the Coloring window (Figure 3.5.44) the new row appears. 

  Click Apply. The entered conditions for the coloring will be applied to the current 

view. Each view can have individual coloring conditions. 
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 If you need to change any parameters of coloring, in the Coloring window, choose the 

desired row, and click on the Edit icon. 

 If you need to delete any coloring condition, select this condition and click on the 

Delete icon. 

 

 

3.5.19 Row limit 

 

 This Tariscope feature can be used to limit the number of records displayed in a view 

which satisfies the filtering criteria for the current view. It can be used for faster opening a 

view with a lot of records or when you need to create a report based on the current view. In 

the last case the report contains all data that meets the filter conditions for the current view, 

and not only those that are displayed. Anytime the user can disable the limit to display all 

rows. 

 To set limits on the number of rows that are displayed in a view, select in the program 

menu: Data → Rows limit. The Record limit window appears as shown in Figure 3.5.46. 
 

 
Figure 3.5.46 

 

 The window has two check boxes: 

• Show all records. 

• Limit. 

 Choose the Limit check box, and specify the required number of records for display. 

Click OK. 

 By default, the 1000 records are set in the Limit box. When the limit is set, the 

appropriate information is displayed in the top row of a view. An example of the view with 

such information is shown in Figure 3.5.47. 

 

 
Figure 3.5.47 
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 The information line contains information about a total number of records and a 

number of records that are displayed. Also there is a link that allows displaying all records. 

 

 

3.5.20 Copying data 

 

 When you need to copy one or a few cells, rows of the table with call records, select 

theirs and right-click anywhere in the table except the header. In the appeared menu (Figure 

3.5.43), select Copy. Another option for copying information is the selection in the main 

menu: Edit → Copy. 

 

 

3.5.21 Recharge selected records 

 

Sometimes you need to rerate one or a few calls. It can be needed, for example, when 

you change parameters of a rate, subscriber or currency. 

 To do this, select the desired records in a view for calls and right-click. In the appeared 

menu (Figure 3.5.43), select the Recharge selected records item. The selected records will 

be rerated. 

 

 

3.5.22 Delete selected records  

 

 If you wish to delete some records from a view for calls, select the desired records and 

right-click. In the appeared menu (Figure 3.5.43), select the Delete selected records item. 

The selected records will be deleted. 

 

 

3.5.23 Record details 

 

 A view of call contains a large list of fields. However, a number of telephone systems 

(telephone exchanges) can have fields that are not included in this list, but they are contained 

in CDR. Tariscope allows you to store information for all the fields provided by a telephone 

system in the database. A list of such telephone systems are specified below:  

• CS1000, Meridian 1 (Avaya-Nortel); 

• Cisco Unified Communications Manager (Cisco Systems); 

• CallManager Express (Cisco Systems). 

 

 If the Tariscope administrator has configured the system to save all the received fields 

and you want to display this information for one record or a group of records in the view, 

select the desired call records and right-click in the table. In the menu that appears (Figure 
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3.5.43) select Record details. The Call details view is appeared, an example of which is 

shown in Figure 5.3.47. 

 

 
Figure 3.5.47 

 

 This view provides features that are available through context menus. 

 If you right-click on the table header, the menu appears that contains the following 

items: 

• Hide field. The item allows you to hide a selected column. 

• Select fields. The item allows to opening the Select fields window that provides a 

choice of desired fields and their order.  

Also you can change an order of the fields using drag and drop. 

 When you set a focus on a column header, Tariscope displays a brief description of the 

field as shown in Figure 3.5.47. 

 If you right-click in any place of the table except the header, another menu appears 

that contains the following items: 

• Hide empty columns. Allows hiding a selected column. 

• Rows as columns. It allows turning the table so that the columns become the rows and 

vice versa. 

• Copy. Provides copying data from selected cells. 

• Select all. Provides data selection of the entire table. 

• Print preview. Opens the Preview view that is described in Section 3.5.16. 

• Find. Opens the Find window that is described in Section 3.5.6. 

• Bookmark. Allows to set a bookmark on the selected record. 

• Export to PDF. Provides an export to a file of the PDF format. 

• Export to CSV. Provides an export to a file of the CSV format. 

• Export to HTML. Provides an export to a file of the HTML format. 

• Export to Excel. Provides an export to a file of the Excel format. 

• Filter by selection. Provides a filtering by a value of the selected cell. 

• Exclude selection. Provides a filtering when rows that include a value of the selected 

cell are excluded. 

• Clear filter. Provides clearing filter conditions. 

 

 In this window, the Tariscope user can explore information that was not included in 

the view for calls.   
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 It is recommended for a complete analysis of these data to create a desired report form 

using Report Designer that is included in Tariscope or Microsoft SQL Server Report 

Builder. 

 

 

3.5.24 View style 

 

 Tariscope allows a user to set an individual style for any Tariscope view. To do this, 

select a desired view and right-click on any place except the table header. The menu appears 

that is shown in Figure 3.5.43. Select the View style item. The Table view settings window 

appears as shown in Figure 3.5.48. 

 

 
Figure 3.5.48 

 

 To change a view font, click on the “…” button located near the Font box. The Font 

window appears. Set the desired parameters. 

To change a background color, click on the “…” button located near the Background 

color box. The Color window appears. Select a desired color. 

To better distinguish different row in the table, you can set an alternate background 

color. In this case the main background color will be applied for first row of the table, the 

alternate background color will be applied for second row, and so on. Click on the "..." button 

located near the Alternate background color box. The Color window appears. Select a 

desired color. 

To apply the alternate background color, select the Use alternate check box. 

Click OK. The settings of the Table view settings window will be applied to the view. 

 

 

3.6 Reports 

 

 The Tariscope user has two ways to create reports in Tariscope: 

1. You can print or export data of any Tariscope view or create diagrams. Hereafter, we 

will call such reports as "simple reports". You can create a simple report using data 

from: 

• views for calls, 

• views for IP traffic, 
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• view for services, 

• table of subscribers, 

• table of rates, 

• and others. 

You can create diagrams only for views for calls, services, and IP traffic. A generation 

of simple reports is executed by an initialization of the following modes: printing, 

creation of diagrams or data export. Prior to creating such reports, the user can filter 

out the necessary data, perform sorting by several criteria, perform grouping data for 

specific fields of the view. Creating such reports is considered in Section 3.5. 

2. You can use a report form. A generation of reports can be initiated manually by the 

user or formed automatically on a predetermined schedule using the Tariscope Tasks 

mode. The Tariscope system includes about 100 report forms. Supports the report 

forms that are created in Tariscope using the Report Designer program or created by 

using the Microsoft Report Builder program. The Tariscope user can edit any report 

form or create your own report form. 

 

The use of report forms allows you to build almost any desired report in tabular or 

graphical form on any data contained in the Tariscope database. These report forms are based 

on SQL queries to the database. They can contain scripts for an additional data processing 

and support formatting output. The report forms allow you to insert graphics such as your 

company logo, signature, etc. 
 

 To generate reports, you can use the following ways: 

• in the menu of the Tariscope program, select: Data → New report; 

• If you are the user of the Tariscope Provider edition, select in the menu: Tool → 

Subscriber accounting. In the appeared Account view, select a desired customer 

(subscriber), and click on the New report icon on the toolbar; 

• in the Tariscope menu, select Tools → Tariscope management. In the appeared All 

configuration pages, click on the Tariscope Tasks in the configuration tree. On the 

Tariscope Tasks page, click on the Configure link, and add a task to generate a report. 

On this page you can configure a schedule and other parameters of the report, which 

will be generated automatically at a specific time. Tariscope can automatically send a 

report by email. See the description of the page configuration in “Tariscope 4.x. 

Administrator’s guide”. 

 

The report forms are grouped. A group name corresponds to the folder name where 

files with the report forms are stored. The Tariscope user depending on the format of the 

report form can edit any report form or create a new report form. The Report Designer 

program or Microsoft Report Builder can be used for this purpose. 

  

 To create a report on calls, open a view for calls. If necessary, specify filter conditions. 

Select Data → New report or the corresponding icon on the toolbar. The Choose report 

window appears as shown in Figure 3.6.1. 
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Figure 3.6.1 

 

This window has the following partitions: 

• Reports, 

• Available reports, 

• Period, 

• Filter, 

• Search, 

• Type, 

• Variables, 

• Information. 

 

 The Reports partition contains a list of groups with report forms. The Recent group 

contains 20 last reports which were generated by the user regardless of to which group these 

forms are belonged. A choice of a group in this partition leads to the display of a list of report 

forms included in the group in the Available reports partition. If you select the All reports 

group, a report tree is displayed in the Available report partition. This example is shown in 

Figure 3.6.1. 

 

 The Search partition located on the right from the Available reports name allows you 

to quickly search a desired report form by its name or part of its name. An example of the 

search of ‘categories’ is shown in Figure 3.6.2. 

 

If the All reports group was selected in the Reports partition, the Available reports 

partition displays report forms of all groups in a form of tree. To open a specific group of 

report forms in the Available reports partition, click on the plus symbol located on the left 

of a group name. Then, select a desired report. 

If you have selected a report form, the Information partition displays the report data 

that contain the following information: a report name, description, author, creation date, and 
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screenshot. An example on such information is shown in Figure 3.6.3. If you click on the 

screenshot, it will be zoomed in. 

 

 
Figure 3.6.2 

 

 
Figure 3.6.3 

 

 The Period list allows you to set a time period which will applied to select data of the 

report. The options include: 

• No filter (by default). All data on a view will be used for the report. 

• Month. Leads to opening the Year and Month lists that allows you to select a desired 

month. 
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• Year. Leads to opening the Year list that allows you to select a desired year. 

• Custom period. Leads to opening the From and To calendar boxes that allow you to 

select a desired period. 

 

 The Filter list allows specifying filter conditions from a previously saved filters. The 

default value is Active view filter. It means that for the report will be used the data, which 

are displayed in the current view. If you need periodically create a report, for example, for 

different groups of subscribers, we recommend you to create and save appropriate filters. 

And when you need a specific report, you should only select a name of the corresponding 

filter in this window. 

 

 The Variables partition is displayed only in case when variables are used in the reports. 

The partition displays a list of variables used in such report and allows specifying particular 

values for them. An example of the Choose report window for report form with variables is 

shown in Figure 3.6.3. This partition located in the bottom of the window is a table containing 

the following columns: 

• Variable. Displays a variable name. 

• Data type. Displays a variable type. 

• Value. Allows you to specify a value of the variable. 

• Description. Displays a variable description. 

 

 To set a value of a specific variable, click in the appropriate cell of the Value column. 

Depending on the variable type, you can enter the data into the cell or additional window that 

opens where you can select a desired value. 

 

 After you specify all required data, click OK. As a result, a new view with name as 

the report title will be opened in the Tariscope program. The view displays the report. An 

example of such view is shown in Figure 3.6.4. 

 

 
Figure 3.6.4 
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A report view contains a menu that appears when you right-click on the view. There 

are the following items in the menu: 

• Copy. Allows copying a selected cell of report table. 

• Find. A choice of the items leads to appear the Find window (Figure 3.5.9). It 

allows to specify data you need. A description of the window, see in the Section 

3.5.6. 

• Print. Allows printing a report. 

• Export to Excel. Allows exporting a report to the Excel file. 

• Export to PDF. Allows exporting a report to the PDF file. 

• Export to HTML. Allows exporting a report to the HTML file. 

• Export to text. Allows exporting a report to the text file. 

 

If you have any problems with a report, open the Output view. To do this, in the 

program menu, select View → Output. The Output window appears where in the Show 

output from list, select the Report items. Information about results of building the report is 

displayed in the window. It contains SQL queries, which were performed to generate the 

report, and errors, if they have appeared. The Tariscope user can edit a report form to avoid 

the errors. Use the Tariscope Report Designer or Microsoft Report Builder depending on 

what tool was used to create the report form.  

If data for the report has been changed or you have changed the report form, click F5 

on the keyboard or the Refresh icon on the toolbar to update the report. 

A list of report forms that Tariscope includes is shown in Table 3.9. 

 

Table 3.9 

 

# Report name Description 

Generalized reports 
1 Calls grouped by the dialed 

numbers-2 

The report displays summary data on outgoing calls of each 

subscriber. The data in the report is grouped by the telephone 

numbers that have been dialed by subscribers. 

2 Communication providers The report displays the generalized data on the calls made 

through certain communication providers. 

3 Equipment summary The report allows you to get information about using different 

communication equipment. 

4 Generalized by authorization code, 

ordered by price 

The report displays the generalized data on the calls with an 

authorization code. 

5 Generalized by call destination 

cities 

The report displays summary data on the cost of calls in certain 

locations. 

6 Generalized by call destination 

countries 

The report displays summary data on the cost of calls to certain 

countries. 

7 Generalized by call sources The report displays summary data grouped by call sources 

(cities, countries). 

8 Generalized by communication 

equipment 

The report displays summary data on the different types of 

calls made through a specific telephone system for a selected 

time period. 

9 Generalized by groups The report displays the generalized data on the calls that are 

made by subscriber groups of the first, second, and third levels. 
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10 Generalized by groups of 2,3 

levels 

The report displays the generalized data on the calls that are 

made by subscriber groups of the second and third levels. 

11 Generalized by mobile operators The report displays call information grouped on mobile 

operators. 

12 Generalized by the sources of 

incoming calls 

The report displays summary data for each source telephone 

number. 

13 Generalized calls grouped by the 

dialed numbers 

The report displays summary data on outgoing calls of each 

subscriber. The data are grouped by the dialed telephone 

numbers. 

14 Generalized calls grouped by 

authorization codes 

The report displays the generalized data on the calls made 

using an authorization code. 

15 Generalized categories The report displays summary data on outgoing calls to phone 

numbers assigned to a certain category. 

16 Generalized data on the groups of 

the 2nd level 

The report displays the generalized data on the calls that are 

made by subscriber groups of the second level. 

17 Generalized for all groups The report displays the generalized data on the calls that are 

made by subscriber groups of all levels. 

18 Generalized groups and 

subscribers 

The report displays generalized data on all subscriber groups 

and subscribers. 

19 Node charges per day The report displays the telecommunication node charges per 

day. 

20 Nodes summary The report displays summary data on the different types of 

calls made through different telecommunications nodes for a 

selected period of time. 

21 Routes and gateways The report displays summary data on calls made via specific 

routes (channels or lines) or gateways. 

22 Subscribers (extended) The report displays subscriber charges for different call types. 

23 Subscribers (ordered by 

extensions) 

The report displays total charges regardless of the type of call 

(local, toll and the like) for each subscriber for the selected 

time period. The information is ordered by the subscribers' 

extensions.  

24 Subscribers (ordered by name) The report displays calls data of all subscribers that are ordered 

by the subscriber's name. 

25 Subscribers expenses per day This report displays the cost of telephone calls per subscriber 

for each day of the selected time period. 

26 Subscribers expenses per month The report displays a total cost of telephone calls for each 

subscriber for the chosen month. 

27 Subscribers summary charges The report displays summary charges of subscribers. 

28 Termination reasons of subscribers 

(incoming calls) 

The report displays summary data on terminate reasons of 

incoming calls to each subscriber. 

29 Termination reasons of subscribers 

(outgoing calls) 

The report displays summary data on terminate reasons of 

outgoing calls to each subscriber. 

30 The costs of communication by 

months 

The report displays the generalized cost of telephone calls, 

each node communication, and PBXs for each month. 

31 The number of days with 

processed calls 

The report displays data on the number of calls during each 

day of the selected time period. 

32 Trunks (channels) The report displays the generalized data on the calls made 

through each trunk (channel), which is connected to PSTN. 

Detailed reports 
1 Detailed by authorization code The report provides detailed information on all the calls made 

with the use of authorization codes. 
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2 Detailed by call destination places The report provides detailed information on all calls made to 

certain destinations or on mobile operators. 

3 Detailed by call source origins 

(incoming calls) 

The report provides detailed information on all incoming calls 

from a certain place. 

4 Detailed by subscribers, ordered 

by numbers 

The report provides detailed information on each subscriber. 

Displays all the calls made by a subscriber, which are grouped 

according to the call type. In the report information on 

subscribers is ordered by internal telephone numbers 

(extensions) in ascending order. 

5 Detailed calls view The report provides details on calls. 

6 Detailed group-subscribers The report provides detailed information on the cost of each 

call and each subscriber that belongs to groups of 1-3 levels. 

7 Detailed in groups (3 levels) The report provides detailed information on the cost of calls of 

each subscriber and each caller group of 1, 2, and 3 levels. 

8 Detailed of single group The report provides detailed information on the call costs of 

subscribers belonging to the groups of the 1st and 2nd levels. 

9 Detailed on calls to mobile 

operators 

The report provides detailed information on all calls made to 

the phone numbers of mobile operators. The output 

information is grouped by mobile operators. 

10 Detailed on subscribers (with 

project codes) 

The report provides detailed information on all calls of each 

subscriber. The calls are grouped by the call type. Displays 

information on a project code for those calls where it was used. 

11 Detailed on subscribers, ordered 

by name 

The report provides detailed information on each subscriber. 

Displays all the calls made by a subscriber. Calls are grouped 

by the call type. In the report information on subscribers is 

ordered by name in ascending order. 

12 Detailed by project codes The report provides detailed information on all calls made with 

the use of a project code. 

13 Details by the destinations of 

outgoing calls 

The report provides detailed information on all calls made on 

a certain destination (city or mobile operator). 

14 Details for calling numbers 

(incoming calls) 

The report provides detailed information on all incoming calls. 

The information is grouped by telephone numbers. 

15 Details for categories The report provides detailed information on all the calls to 

phone numbers that belong to special categories. 

Statistical reports 
1 Daily cost (chart) The report provides information on costs of all days and builds 

a chart. 

2 Departments with the largest 

duration of calls 

The report provides information on subscriber groups with the 

largest durations of calls. 

3 Departments with the largest 

number of calls 

The report provides information on subscriber groups with the 

largest number of calls. 

4 Groups of subscribers with the 

largest cost of calls (chart) 

The report allows you to get information on 20 subscriber 

groups with the largest cost of calls and builds a chart. 

5 Groups of subscribers with the 

largest duration of calls (chart) 

The report allows you to get information on 20 subscriber 

groups with the largest duration of calls and builds a chart. 

6 Groups of subscribers with the 

largest number of calls (chart) 

The report allows you to get information on 20 subscriber 

groups with the largest number of calls and builds a chart. 

7 Subscribers numbers by categories The report provides information on number of subscribers and 

extensions by the following categories: service, personal 

entity, and legal entity. 

8 Subscribers with the largest 

charges for calls (chart) 

The report allows you to get information on 20 subscribers 

with the largest charges for calls. A chart is built. 
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9 Subscribers with the largest 

number of calls (chart) 

The report allows you to get information on 20 subscribers 

with the largest number of calls. A chart is built. 

10 Subscribers with the largest total 

duration of calls (chart) 

The report allows you to get information on 20 subscribers 

with the largest total duration of calls. A chart is built. 

11 Summary report on equipment 

(chart) 

The report allows you to get summary report on telephone 

systems. A chart is built. 

12 A change of number of subscribers 

and services 

The report provides information on a change of number of 

subscribers and services. 

13 The longest outgoing calls The report provides information on the longest outgoing calls. 

14 The most expensive calls The report provides information on the most expensive calls. 

15 The most expensive calls (chart) The report allows you to get information on 20 the most 

expensive calls. The report contains a chart. 

16 The most expensive departments The report provides information on subscriber groups with the 

most expensive costs for calls. 

17 The most expensive subscribers The report provides information on subscribers with the most 

expensive costs for calls. 

18 The most long-lasting calls (chart) The report allows you to get information on 20 with the longest 

calls. A chart is built. 

Operations 
1 Assessment of services for the past 

month 

The operation charges periodic services for all subscribers for 

the past month. The services can be, for example, a month fee, 

web hosting, etc. We recommend you to use the appropriate 

mode of the Tariscope program instead of this operation. 

2 Change the duration of a call The operation allows you to change the duration of a particular 

call and recalculate the cost of the call. 

3 Charge all periodic services for the 

current month 

The operation executes charging periodic services (for 

example, month fee, web hosting, etc.) for the current month. 

4 Cleaning charges of on-line billing The operation cleans charges of the on-line rating. 

5 Cleaning charges of services per 

month 

The operation allows you to delete all periodic charges (a 

month fee, web hosting, etc.) to all subscribers for the selected 

month. 

6 Cleaning charges on-line billing 

and call data 

The operation allows you to delete charging call costs to all 

subscribers for the selected month. Periodic and manual 

services are not deleted. 

7 Clear all data for month The operation allows you to delete information about calls on 

all the telecommunications nodes for the selected month and 

clear appropriate charges to the subscribers' accounts. 

8 Clearing accounts of subscribers 

except for payments and allocation 

The operation clears subscribers' accounts except the 

subscribers' payments and charges are made manually with the 

description "recalculate". 

9 Merge nodes The operation allows you to move all the data of telephone 

systems and subscribers from one node to another. 

10 Recalculation of charges on-line 

charging for monthly subscriber 

The operation performs a comparison of the cost of urban, 

long-distance, and international calls and calls to mobile 

operators for a particular subscriber for the chosen month with 

appropriate amounts credited to the account of the subscriber. 

In case of differences the subscriber's account is recalculated. 

11 Reset charges for subscriber 

(restriction feature) 

Charges for telephone calls are reset when the restriction 

feature is used. 

12 Transfer calls and their costs to 

another subscriber 

The operation transfers all calls that are in view, and their costs 

to another subscriber. 
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13 Calculation for services of selected 

month 

The operation calculates periodic services for a selected 

month. 

Provider reports 
1 Classification of subscribers per 

month 

The report generates information about charges, payments and 

debts of all subscribers in a given month. 

2 Envelope Allows printing an envelope. 

3 Internet traffic per month Allows getting Information about Internet traffic of a specific 

subscriber. 

4 Invoice A4 A generic invoice report. 

5 Invoice A4 2 pages A generic invoice report with call details on the second page. 

6 Receipt Allows getting a receipt for a subscriber. 

7 Subscriber calls details Allows getting details on calls of a selected subscriber. 

8 Subscriber information The report provides information on charges, payments, and 

balances of a particular subscriber for the chosen period. 

9 The analysis of overdue payments The report provides information on overdue payments on 0, 

30, 60, and 180 days. 

10 The envelope without recipient 

data 

Allows printing on an envelope without recipient. 

Service reports 
1 Database summary The report provides summary information on the Tariscope 

database. 

2 No extensions in the subscribers' 

database 

The report provides information on extensions that there are in 

call table but is absent in the subscribers' table. 

3 Free numbering capacity of PBX The report provides information on a free numbering capacity 

of a telephone system. 

4 Summary The report provides a summary information on the Tariscope 

server. 

Service subreports 
1 Adds all the numbers from the list 

in the database of subscribers 

Adds all the numbers from the list in the subscribers' database. 

2 Appends a number in the database 

of subscribers 

Appends an extension to the subscribers' database. 

3 Available extensions in range Displays a list of available extensions in a selected range. 

Call Center reports 
1 Call center summary for a period 

of time 

The report provides a summary information for a certain time 

period. 

2 Detailed operator logins The report is intended for 3CX Phone System. It shows a 

beginning and end of session when operator uses *62/*63 dial 

codes to login/logout queue. 

3 Operator stats for a period of time The report provides statistics on calls of an operator for a 

period of time. 

4 Operators group for a period of 

time 

The report provides statistics on calls of operators' group for a 

period of time. 

CUCM reports 
1 CUCM Jitter The report provides information on jitters in VoIP calls based 

on CMRs. 

2 CUCM K-factor data The report allows analyzing K-factor data from CRMs. 

3 CUCM Latency The report provides information on latency in VoIP calls based 

on CMRs. 

4 CUCM Lost packets The report provides information on lost packets in VoIP calls 

based on CMRs. 
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Subscribers limiting 
1 Expenses of subscribers by 

categories 

Provides information on expenses of subscribers by categories 

when the restriction feature was used. 

2 Restricted subscribers Provides a list of restricted subscribers. 

External data 
1 All services The report contains all charged services for a certain period of 

time. Charges are grouped by service name. 

 

 If you wish that Tariscope automatically generate reports by schedule, use the 

Tariscope Tasks configuration page from the Tariscope Management mode. A description of 

the configuration page, see in the “Tariscope 4.x. Administrator’s guide”.  

 

 

3.7 Views for charts 

 

 The reports discussed in Section 3.6 can contain both text and graphical information. 

At the same time, the Tariscope program has a separate Chart function that allows you to 

quickly create a chart based on the data of views for calls. 

 Consider creating a chart based on the following example. We wish to know the 

distribution of the costs of all subscribers on long-distance calls. 

 We open a view for calls. Using the filtering we select only long-distance calls. 

 Since we are interested in the distribution of costs of all subscribers, we hide all 

columns of the view except the To destination and Cost columns. Then we group 

information by the To destination field. We sort the data by the Cost column. The view will 

be as shown in Figure 3.7.1. 

 

 
Figure 3.7.1 

 

 Since we are interested in the basic costs on calls, we select only first ten cells in the 

Cost column. Then we select in the program menu: Data → New chart or we can click on 

the Chart icon on the toolbar. The Chart settings window appears as shown in Figure 3.7.2. 
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Figure 3.7.2 

 

 The Style list allows you to select a desired style from the following options: 

• Area; 

• Histogram; 

• Line; 

• Pie. 

 

In the Name box, the user can change a chart name that is offered by default. 

The Data range box displays the selected cells of the table. You can change the range. 

To do this, click on the '...' button located on the right from the box. The Select range window 

appears where you should select a desired cell range. 

The Legend in first column list displays the column name, which is used as a legend 

in the chart. You can change a default value. 

The Series in row and Series in column check boxes allows setting a type of 

displaying the legend. 

 We select the Pie style for our example and get the chart as shown in Figure 3.7.3. 

Figure 3.7.3 

 

 A view for charts allows to save the chart as a picture. To do this, click on the Save as 

icon on the toolbar of the view. 
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 Also you can print a chart. To do this, click on the Print icon on the toolbar of the 

view. 

 

 

 

3.8 Processing a CDR file 

 

 CDR is an abbreviation of 'Call Detail Record'. Vendors of some PBXs use the other 

abbreviations for such data, for example, SMDR and so on. 

 If you have a CDR log with information about made calls generated by the Tariscope 

system or in any other way, then you can run processing this data to place them into the 

Tariscope database. 

 It is assumed that all the necessary settings for processing such information has already 

been made. How to configure the system, see the following document: "Tariscope 4.x. 

Administrator's Guide". 

 In the menu of the Tariscope program, select Parse → Transfer. The Parse calls view 

opens in the program and at the same time the Equipment selection window opens, 

examples of which are shown in Figure 3.8.1. 

 

 
Figure 3.8.1 

 

In the Equipment selection window, select a telephone system, the data from which 

will be processed, and click OK. A name of the selected telephone system will be displayed 

in the Equipment box of the Parse calls view. If the telephone system was selected by 

mistake, click the "..." button to the right of the Equipment box and select a desired PBX. 

 Select the CDR files that you wish to process. To do this, click the Add button. The 

Open window appears. Select one or more CDR files. The selected files will be added to the 

Call detail recording files list. 
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 If you need to delete some of the files from this list, select them and click on the 

Exclude button. 

 To start the processing files, click the Start button. For some PBXs, which have no 

information about the year in the CDR data, the Choose year window appears where you 

should select the year to which the data are related. The processing is started.  Depending on 

the file size, the computer's performance and workload the processing may take some time. 

Details of the processing, such as the number of the processed records, the execution time, 

the projected time of processing are displayed in the view. An example of this view during 

processing is shown in Figure 3.8.2. 
 

 
Figure 3.8.2 

 

 After completion of the processing, the Show parsed calls link is appeared. Click this 

link to open a new view, in which a filter is applied to display only the processed records. 

 Keep in the mind, if you process the same CDR file twice, records for calls from the 

file will be doubled. Select Parse → Find duplicate records, to eliminate the duplicated 

records.   

 

 

3.9 Call rating 

 

 When you use the Tariscope Observer service to process CDR data or process a CDR 

file as it is described in the previous section, the automatic call rating is performed. The rating 

is performed effectively, if there is enough information, that is Tariscope was properly 

configured. 

 In the case that all or part of call records were not rated, you need to find the reason of 

this and perform re-rating of the entire database or selected records. 

 The main reasons that the call cost are absent are the following ones: 

1. The lack of all required data about a subscriber in the Tariscope database. An indication of 

this is the absence of the subscriber name in the From subscriber column of a view. 

2. A rating plan has not been set for a subscriber. 
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3. The connection date of a subscriber is later than the date of the call which does not have 

the cost. 

4. The route parameters, through which the call was performed, had not been configured: 

• There is an access code is in the view but it has not been set in Tariscope. In this case, 

values on the To destination column for long-distance, international calls, and calls 

on the phone numbers of mobile operators are empty. 

• The service provider, the parameters of which should be applied for the rating, has not 

been specified in Tariscope. 

5. The area code, which was used in the call, is absent in the Tariscope database. You can see 

this situation in the view for call. In this case the city name or mobile operator name is absent 

in the To destination column. If there is the required phone code in Tariscope, check 

availability of a rate for this area code. 

 

 To quickly execute the re-rating, we recommend: 

• If you need to re-rate a group of records or a single record, select desired records of 

the call table and right-click. Menu appears. Select the Recharge selected records 

item. 

• If you want to re-rate all calls of a view, select in the program menu: Parse → Rate. 
 

 In the last case the Recharge calls view is opened and at the same time the Action 

parameters window appears as shown in Figure 3.9.1. 

 

 
Figure 3.9.1 

 

 This window allows you to set a filter for the view. As mentioned above we 

recommend you always use a filter if it was not set earlier in the view, or if you want to rerate 

not all calls of the database. By default, the Action parameters window offers the option of 

the Active view filter. If this option is not satisfied you, you can select the other options: 

• No filter. All data of the call database will be rerated. 

• Another filter. This choice makes active the list with names of previously created 

and saved filters. Select a desired filter from the list. 

 

 There are the following additional filter conditions: 

• Month. You can choose a desired month and year from the Month calendar box. 

• Node. You can choose a desired telecommunications node in the Node list. 
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• Subscriber. You can choose a desired subscriber. To do this, click on the "..." button 

located on the right from the Subscriber box and select a subscriber in the Choose 

subscriber window. 

 

 To expedite the processing, select the Use multithreading check box. 

 Click OK. The process of the rating starts. After the end of the process, go to the 

required view and refresh it. To refresh data, click F5 or select the appropriate icon on the 

toolbar. 

 

 If you are a telecom service provider and use the Tariscope Provider edition, you can 

rerate data for a particular month with the possibility of simultaneous charging of all periodic 

services. To do this, select in the program menu: Parse → Recalculate month. The 

Recharge all month view is opened and at the same time the Action parameters window 

appears as shown in Figure 3.9.2. 

 

 
Figure 3.9.2 

 

 In the Month calendar box, select a desired month and year for which calls will be 

recalculated. 

 In the Node list, select a telecommunications node for which the recalculating will be 

performed. 

 If you need to recalculate calls of a specific subscriber, click on the "…" button located 

on the right from the Subscriber box, and select the subscriber. 

 If you need to charge the periodical services for subscribers, select the Charge 

services check box. In this case the previously charged services for the selected month will 

be canceled and recharged. 

 To expedite  the processing, select the Use multithreading check box. 

 Click OK. The process of the rating starts. After the end of the process, go to the 

required view and refresh it. To refresh data, click F5 or select the appropriate icon on the 

toolbar. 
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4 Contact Information 

 

Office address 

Private Enterprise SoftPI,  

Industrialnyj avenue 26, 3rd floor, 

Kharkiv, 

Ukraine 

61007 

 

Contacts for support 
 

E-mail: support@softpiua.com 

 

 

Contacts for purchase or cooperation 

 

E-mail: office@softpiua.com 

 


